View Issue Details

IDProjectCategoryView StatusLast Update
0004697The Dark ModGraphicspublic01.02.2019 05:45
ReporterJudith Assigned Toduzenko  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionTDM 2.06 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004697: Some console commands don't work with GLSL 1 and useFBO 0/1
DescriptionI just went throught commands listed here: http://wiki.thedarkmod.com/index.php?title=Console_Useful_Controls and some of them don't work properly or at all with GLSL and FBO. r_showlightcount 1 2 and r_showShadows 1 2 seem to be broken, while reloadimages results with soft shadows disappearing (FBO 0) or a black screen (FBO 1). First two commands are not super important, but reloadimages is kind of high priority. Mappers need it to reload changed .tga textures to test and tweak materials.

(Also timescale doesn't seem to work on my end, but I got the same problem with 2.05).
Steps To ReproduceLoad any map in 2.06. Try these commands with GLSL set to 1 and FBO set to 0 or 1:

reloadimages
r_showlightcount 1 2
r_showShadows 1 2
TagsNo tags attached.

Relationships

related to 0004917 resolvedcabalistic vid_restart causes buggy shadow map overlays when new shadow map feature is activated 
parent of 0004749 resolvednbohr1more Reloading textures makes the soft shadows disappear 
parent of 0004895 closed g_showEntityInfo 1 is very unusable 
parent of 0004698 assignedstgatilov Timescale command doesn't work with uncapped FPS / com_fixedTic 1 
child of 0004425 resolvedduzenko Framebuffer objects for color, depth, stencil 
child of 0004409 resolvedduzenko Add an option to lift the 60 fps lock 
Not all the children of this issue are yet resolved or closed.

Activities

Springheel

Springheel

22.06.2018 15:02

administrator   ~0010553

I can confirm that reloadimages doesn't work in 2.06, which is definitely problematic for mappers.

timescale, on the other hand, does work fine for me on 2.06.
Judith

Judith

22.06.2018 16:10

reporter   ~0010556

It seems like timescale depends on the Uncapped FPS option, it works for me when it's set to off.
kingsal

kingsal

15.07.2018 18:34

reporter   ~0010687

I have the same problem. Pretty critical as I am constantly reloading images. Glad its being tracked.
nbohr1more

nbohr1more

21.07.2018 04:23

developer   ~0010710

Rev 7586 has a fix for reloadImages
nbohr1more

nbohr1more

21.07.2018 17:35

developer   ~0010713

Rev 7588 has fixed for r_showLightCount and r_showShadowCount
nbohr1more

nbohr1more

21.07.2018 18:32

developer   ~0010714

Rev 7589 has fixed r_showShadows when Soft Shadows are enabled
nbohr1more

nbohr1more

29.12.2018 23:02

developer   ~0011183

All core problems resolved.

Open new tickets regarding anything else found.

Issue History

Date Modified Username Field Change
12.12.2017 08:23 Judith New Issue
20.12.2017 12:52 duzenko Assigned To => duzenko
20.12.2017 12:52 duzenko Status new => assigned
28.05.2018 14:09 stgatilov Priority normal => high
28.05.2018 14:09 stgatilov Product Version => TDM 2.06
28.05.2018 14:09 stgatilov Target Version => TDM 2.07
28.05.2018 14:22 stgatilov Severity normal => major
22.06.2018 15:02 Springheel Note Added: 0010553
22.06.2018 16:10 Judith Note Added: 0010556
10.07.2018 21:30 nbohr1more Relationship added child of 0004425
15.07.2018 18:34 kingsal Note Added: 0010687
21.07.2018 04:23 nbohr1more Note Added: 0010710
21.07.2018 17:35 nbohr1more Note Added: 0010713
21.07.2018 18:32 nbohr1more Note Added: 0010714
21.07.2018 19:36 nbohr1more Status assigned => feedback
21.07.2018 19:36 nbohr1more Fixed in Version => TDM 2.07
25.07.2018 22:14 nbohr1more Relationship added parent of 0004749
16.10.2018 21:54 nbohr1more Relationship added parent of 0004895
19.12.2018 18:05 nbohr1more Relationship added related to 0004917
28.12.2018 14:03 nbohr1more Relationship added parent of 0004698
29.12.2018 23:02 nbohr1more Note Added: 0011183
29.12.2018 23:03 nbohr1more Status feedback => resolved
29.12.2018 23:03 nbohr1more Resolution open => fixed
01.02.2019 05:45 nbohr1more Relationship added child of 0004409