View Issue Details

IDProjectCategoryView StatusLast Update
0004699The Dark ModCodingpublic26.12.2017 19:06
ReporterSpringheel Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004699: Mirror textures broken
Description"And the second is that my mirror now reflects the skybox, is that meant to happen? and if so.. is there a new texture that reflects just the world back?"

http://forums.thedarkmod.com/topic/19162-beta-testing-206/?p=416292
TagsNo tags attached.

Relationships

parent of 0004667 resolved Mirrors are too bright 
related to 0004707 resolvedduzenko Wrong reflection in mirror 

Activities

grayman

grayman

17.12.2017 17:52

administrator   ~0009823

Where is this mirror?

I couldn't find it while cruising through the map in DR.
Goldwell

Goldwell

17.12.2017 17:56

updater   ~0009824

Last edited: 17.12.2017 17:56

View 2 revisions

It's in the bathroom on the top floor of the bathhouse. There's only four rooms on that top level. Just look for the only part of the map that's elevated compared to the rest and then the bathroom up there.

If you're still stuck I can fly there in DR and save it so you start there.

grayman

grayman

17.12.2017 18:00

administrator   ~0009826

I found it.
grayman

grayman

17.12.2017 18:16

administrator   ~0009827

@duzenko,

Is this because of the work we did on the remote camera?

The mirror uses textures/common/mirror and portal sky is used in the same room.
duzenko

duzenko

17.12.2017 20:54

developer   ~0009829

What puzzles me is we had sky and mirrors working in your test map.
Could you attach that map here for reference please?
grayman

grayman

17.12.2017 21:30

administrator   ~0009830

Last edited: 17.12.2017 21:33

View 3 revisions

Yes, sky + mirror works in my test map, but that map uses sky and mirror textures with unique 'map' names.

Bathhouse is an existing mission using standard 2.05 textures.

Map attached. Mirror is located at [-82 248 858].

grayman

grayman

17.12.2017 21:31

administrator  

bh-bathhouse.map (4,998,063 bytes)
grayman

grayman

17.12.2017 21:37

administrator  

bh_mirror.jpg (433,543 bytes)
grayman

grayman

17.12.2017 21:38

administrator   ~0009831

Screenshot attached.

This looks like a different problem than the ones we were solving in my camera test map.
Goldwell

Goldwell

17.12.2017 21:58

updater   ~0009832

If this issue is only with my map I don't mind updating it for 2.06 with a different texture there. I was planning on doing a little update for it anyway to change the briefing video from roq to MP4.
duzenko

duzenko

17.12.2017 22:08

developer   ~0009833

Is the attached map a copy of the map bundled with the FM?
I mean the test map that you build for camera test, with cameras, mirrors, and small water pool.
grayman

grayman

18.12.2017 05:24

administrator  

camera.pk4 (37,657 bytes)
grayman

grayman

18.12.2017 05:24

administrator   ~0009836

camera.pk4 attached.
duzenko

duzenko

18.12.2017 20:19

developer   ~0009837

@Goldwell, can you maybe look at @grayman's map and figure out what makes it work in test map and not in yours.
See the above assumption about "texture name".
Goldwell

Goldwell

19.12.2017 19:43

updater   ~0009839

My map is using the texture "textures/common/mirror" whereas in the camera.pk4 that Grayman attached he is using "mirror1".

In addition to that difference this map is using for the skybox "portal_sky2" whereas my map is using "textures/smf/portal_sky"

I just did a test and if I change the bathroom mirror to the new one the problem is gone in 2.06.

If it needs to be I can simply update the mission with that change when 2.06 rolls out
Goldwell

Goldwell

19.12.2017 19:44

updater  

Goldwell

Goldwell

19.12.2017 19:45

updater   ~0009840

See the attached screenshot: bh_2017-12-20_05.44.20.jpg

Also I just noticed that now the water doesn't display correctly in the mirror whereas it did before. I believe that is just a sorting issue and could tweak with it.
duzenko

duzenko

19.12.2017 19:46

developer   ~0009841

I want to understand what causes this bug.
What did you change exactly in your test?
Can you create a test map with two mirrors - one broken and one working?
grayman

grayman

19.12.2017 20:14

administrator   ~0009842

I need to check all existing maps for combinations like BH.

Changing BH is fine, but we will have a problem if there are more maps suffering the same problem.

The named texture solution might have to support existing maps somehow, since we strive not to break existing maps.
Goldwell

Goldwell

19.12.2017 20:19

updater   ~0009843

@Duzenko I changed the mirror in the upstairs bathroom in BH from "textures/common/mirror" to "mirror1" (which is a new material inside the camera.mtr file inside camera.pk4 that is attached to OP).

That's all I changed and it fixed the problem.

I will create a test map or the broken one and the fixed one for you now and upload it.
Goldwell

Goldwell

19.12.2017 20:31

updater  

bh_mirror_test.pk4 (500,128 bytes)
Goldwell

Goldwell

19.12.2017 20:31

updater   ~0009844

Ok I have added: bh_mirror_test.pk4

Inside that you will find just the player in the room with the two mirrors. On the right is the new "mirror1" and on the left is the original texture used in BH.
grayman

grayman

19.12.2017 21:02

administrator   ~0009845

@duzenko,

Instead of having new materials using the 'map' keyword to uniquely identify different instances of the same material in a mission, is it possible to dynamically assign 'map' keywords to materials as they are used?

Maybe something at map load that interrogates a requested reflective texture and assigns unique 'map' keywords to the texture's attributes so that when the renderer uses them later, they get picked up?

This would solve the problem of supporting existing maps, methinks, and take the onus off of mappers to have to provide unique 'map' attributes for reflective textures in the same PVS.

'reflective' would mean mirrors, reflective water, and portal_sky.
duzenko

duzenko

20.12.2017 11:36

developer   ~0009849

Last edited: 20.12.2017 11:55

View 2 revisions

Maybe just skip sky in mirror altogether? Sky is quite expensive the way it is implemented in TDM, and it has to be re-drawn for every mirror currently.
...
Disregard

duzenko

duzenko

20.12.2017 11:55

developer   ~0009850

At revision: 15123
At revision: 7351

Issue History

Date Modified Username Field Change
17.12.2017 13:40 Springheel New Issue
17.12.2017 17:52 grayman Note Added: 0009823
17.12.2017 17:56 Goldwell Note Added: 0009824
17.12.2017 17:56 Goldwell Note Edited: 0009824 View Revisions
17.12.2017 18:00 grayman Note Added: 0009826
17.12.2017 18:16 grayman Note Added: 0009827
17.12.2017 20:54 duzenko Note Added: 0009829
17.12.2017 21:30 grayman Note Added: 0009830
17.12.2017 21:31 grayman File Added: bh-bathhouse.map
17.12.2017 21:33 grayman Note Edited: 0009830 View Revisions
17.12.2017 21:33 grayman Note Edited: 0009830 View Revisions
17.12.2017 21:37 grayman File Added: bh_mirror.jpg
17.12.2017 21:38 grayman Note Added: 0009831
17.12.2017 21:58 Goldwell Note Added: 0009832
17.12.2017 22:08 duzenko Note Added: 0009833
18.12.2017 05:24 grayman File Added: camera.pk4
18.12.2017 05:24 grayman Note Added: 0009836
18.12.2017 20:16 duzenko Assigned To => duzenko
18.12.2017 20:16 duzenko Status new => assigned
18.12.2017 20:19 duzenko Note Added: 0009837
19.12.2017 19:43 Goldwell Note Added: 0009839
19.12.2017 19:45 Goldwell File Added: bh_2017-12-20_05.44.20.jpg
19.12.2017 19:45 Goldwell Note Added: 0009840
19.12.2017 19:46 duzenko Note Added: 0009841
19.12.2017 20:14 grayman Note Added: 0009842
19.12.2017 20:19 Goldwell Note Added: 0009843
19.12.2017 20:31 Goldwell File Added: bh_mirror_test.pk4
19.12.2017 20:31 Goldwell Note Added: 0009844
19.12.2017 21:02 grayman Note Added: 0009845
20.12.2017 11:36 duzenko Note Added: 0009849
20.12.2017 11:55 duzenko Note Added: 0009850
20.12.2017 11:55 duzenko Status assigned => resolved
20.12.2017 11:55 duzenko Fixed in Version => TDM 2.06
20.12.2017 11:55 duzenko Resolution open => fixed
20.12.2017 11:55 duzenko Note Edited: 0009849 View Revisions
23.12.2017 08:15 stgatilov Relationship added related to 0004707
26.12.2017 19:06 nbohr1more Relationship added parent of 0004667