View Issue Details

IDProjectCategoryView StatusLast Update
0004667The Dark ModCodingpublic26.12.2017 19:07
ReporterVanishedOne Assigned To 
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.06Fixed in VersionTDM 2.06 
Summary0004667: Mirrors are too bright
DescriptionSee attached image.
Additional InformationIt doesn't happen when there is no light.
TagsNo tags attached.

Relationships

related to 0004615 resolvedduzenko Remote camera lost when saving\loading 
child of 0004699 resolvedduzenko Mirror textures broken 

Activities

VanishedOne

VanishedOne

13.11.2017 01:55

developer  

206mirror.png (896,898 bytes)
duzenko

duzenko

13.11.2017 10:40

developer   ~0009595

Last edited: 13.11.2017 10:46

View 4 revisions

Could you attach a download link for this map?
Or point to an existing fm?

The mirror in cook's room in St Alban Caduceus looks normal.

VanishedOne

VanishedOne

13.11.2017 15:45

developer  

mirror.map (5,552 bytes)
VanishedOne

VanishedOne

13.11.2017 15:48

developer   ~0009600

Last edited: 14.11.2017 15:48

View 2 revisions

Attached.

r_useFBO seems to be affecting global brightness, but I've checked and the mirror is brighter than the scene above with both r_useFBO 0 and r_useFBO 1. Edit: the global brightness thing is probably 0004669.

duzenko

duzenko

14.11.2017 19:15

developer   ~0009615

Sorry, I can't debug the .map because I am clueless with DR.
Can you move the relevant materials in a separate .mtr file?
But I think this might be because the mirror lacks the solid background behind it. Try to copy paste the mirror from St Albans Caduceus or remote camera test map and see the difference.
VanishedOne

VanishedOne

14.11.2017 19:38

developer   ~0009618

That's TDM's basic mirror material. Now that I look, I see it's been changed:

2.05 version:

textures/common/mirror
{

    description "used for mirror subrenders"

    discrete // never merge with other surfaces
    qer_editorimage textures/common/mirror.tga
    solid
    mirror
    {
        blend add
        map textures/common/mirror.tga
    }


}


2.06 version:

textures/common/mirror
{

    description "used for mirror subrenders"

    discrete // never merge with other surfaces
    qer_editorimage textures/common/mirror.tga
    solid
    mirror
    {
        blend add
        mirrorRenderMap
        map textures/common/mirror.tga
    }


}

Related to 0004615 changes?

My guess it that either blend add is causing the brightness (in 2.05 it would do nothing because textures/common/mirror.tga doesn't exist, but now maybe mirrorRenderMap gives it something to add) or mirror and mirrorRenderMap are having some kind of combined effect.
VanishedOne

VanishedOne

14.11.2017 20:32

developer   ~0009621

Last edited: 14.11.2017 20:47

View 3 revisions

textures/washroom/mirror has the same brightness as the reflected scene (in 2.05 it's darker but that's because of a blend stage that got removed). In 2.06 it also uses both mirror and mirrorRenderMap.

With mirror alone it's black after dmap. I'm trying to manipulate the material to narrow things down (among other things, for some reason 2.06 textures/washroom/mirror has no discrete keyword) but I'm getting dmap crashes.

Edit: definitely looks as though the brightness comes from additive blending in the mirrorRenderMap stage. Though the underlying bug is that the mirror keyword isn't working, which is why the 2.05 versions of the materials weren't functioning.

duzenko

duzenko

15.11.2017 20:04

developer   ~0009623

Can you try the remote camera test map and see if it works for you?
VanishedOne

VanishedOne

15.11.2017 20:54

developer   ~0009624

I wasn't sure which one, but I checked camera.map from 0004615 and when I go near the second screen, the first one changes to have the same view as the second.
duzenko

duzenko

15.11.2017 23:26

developer   ~0009625

Last edited: 15.11.2017 23:29

View 3 revisions

That was work in progress but it does not have the brightness issue?
Here's the latest Grayman's version: http://forums.thedarkmod.com/index.php?app=core&module=attach&section=attach&attach_id=15171

Also: http://forums.thedarkmod.com/index.php?app=core&module=attach&section=attach&attach_id=15113

But best example is any released map such as Inn Business or St Albans Caduceus.

VanishedOne

VanishedOne

16.11.2017 00:46

developer   ~0009626

I don't have access to those links. I noted in http://forums.thedarkmod.com/topic/19162-beta-testing-206/page-2#entry414153 that In the Black (in beta testing) is affected.

It seems from my examinations there are two separate brightness differences with 2.06 materials. textures/common/mirror is overbright in 2.06 because it additively blends in mirrorRenderMap, which it doesn't in 2.05. (Which is unexpected when it should be adding to black void, but I have tested the material with and without additive blending.) textures/washroom/mirror is brighter than 2.05 because of a missing blend gl_dst_color,gl_zero stage. In both cases the strength of the difference can depend on the brightness of the scene that's being reflected: in 2.06 textures/common/mirror the scene is blended as a source image, in 2.05 textures/washroom/mirror it's blended as a destination image.

It should be possible to improve how the materials are set up, but it would still be treating the symptoms rather than making the original materials work properly, and might just produce other bugginess.
nbohr1more

nbohr1more

26.12.2017 19:07

developer   ~0009891

Fixed under 4699

At revision: 15123
At revision: 7351

Issue History

Date Modified Username Field Change
13.11.2017 01:55 VanishedOne New Issue
13.11.2017 01:55 VanishedOne File Added: 206mirror.png
13.11.2017 10:40 duzenko Note Added: 0009595
13.11.2017 10:40 duzenko Note Edited: 0009595 View Revisions
13.11.2017 10:45 duzenko Note Edited: 0009595 View Revisions
13.11.2017 10:46 duzenko Note Edited: 0009595 View Revisions
13.11.2017 15:45 VanishedOne File Added: mirror.map
13.11.2017 15:48 VanishedOne Note Added: 0009600
14.11.2017 15:48 VanishedOne Note Edited: 0009600 View Revisions
14.11.2017 19:15 duzenko Note Added: 0009615
14.11.2017 19:38 VanishedOne Note Added: 0009618
14.11.2017 19:40 VanishedOne Relationship added related to 0004615
14.11.2017 20:32 VanishedOne Note Added: 0009621
14.11.2017 20:36 VanishedOne Note Edited: 0009621 View Revisions
14.11.2017 20:47 VanishedOne Note Edited: 0009621 View Revisions
15.11.2017 20:04 duzenko Note Added: 0009623
15.11.2017 20:54 VanishedOne Note Added: 0009624
15.11.2017 23:26 duzenko Note Added: 0009625
15.11.2017 23:28 duzenko Note Edited: 0009625 View Revisions
15.11.2017 23:29 duzenko Note Edited: 0009625 View Revisions
16.11.2017 00:46 VanishedOne Note Added: 0009626
26.12.2017 19:06 nbohr1more Relationship added child of 0004699
26.12.2017 19:06 nbohr1more Status new => resolved
26.12.2017 19:06 nbohr1more Resolution open => fixed
26.12.2017 19:06 nbohr1more Fixed in Version => TDM 2.06
26.12.2017 19:06 nbohr1more Target Version => TDM 2.06
26.12.2017 19:07 nbohr1more Note Added: 0009891