View Issue Details

IDProjectCategoryView StatusLast Update
0004707The Dark ModGraphicspublic31.12.2017 12:22
Reporterstgatilov Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionno change required 
Product VersionTDM 2.06 
Fixed in VersionTDM 2.06 
Summary0004707: Wrong reflection in mirror
DescriptionSometimes reflection in the mirror is black, sometimes it is lit incorrectly.
Steps To Reproduce1. Load "Accountant 2" Mission.
2. Get to the elevator (sorry, cannot explain it better).
3. On the second floor, enter Griswold apartment.
4. Go through the corridor and turn right on the first possibility.
5. You are in the dining room, go to the door at the end of the room and open it, do not enter.

Now there three cases:
1. You look directly at the mirror through the door: the image is correct.
2. You look from the floor height (need noclip) or from the side: the mirror is black.
3. You look from the ceiling (need noclip): the reflection is visible, but it is not lit correctly (some light source is excluded).
Sometimes you can even see partially black screen.
Additional InformationThis happens on latest 2.06 beta.
On the previous version (before 7351 and 15123) you could also see start and sky in the mirror in some cases. Now I don't get skybox.
TagsNo tags attached.

Relationships

related to 0004699 resolvedduzenko Mirror textures broken 
related to 0004632 closedduzenko Mirror is black: no reflection (Inn Business) 

Activities

stgatilov

stgatilov

23.12.2017 08:10

administrator  

mirror_black.jpg (506,815 bytes)
stgatilov

stgatilov

23.12.2017 08:10

administrator  

mirror_correct.jpg (505,361 bytes)
stgatilov

stgatilov

23.12.2017 08:10

administrator  

mirror_black2.jpg (539,330 bytes)
stgatilov

stgatilov

23.12.2017 08:10

administrator  

mirror_light_lacking.jpg (451,937 bytes)
stgatilov

stgatilov

23.12.2017 08:11

administrator  

stgatilov

stgatilov

23.12.2017 08:11

administrator  

Darkmod.cfg (11,967 bytes)
stgatilov

stgatilov

23.12.2017 08:14

administrator   ~0009867

I have attached the screenshots with various cases + config file I use.
stgatilov

stgatilov

23.12.2017 08:30

administrator   ~0009868

Ok, I have checked this place in 2.05.
I see cases 1 and 3 only. So the lack of lighting is reproduced even in 2.05. But the mirror never got completely black (or mostly black) in 2.05.
duzenko

duzenko

31.12.2017 09:59

developer   ~0009949

Last edited: 31.12.2017 09:59

View 2 revisions

This appears to be a portal bug.
The bathroom door portal is closed when it should not.
Not sure why though.

duzenko

duzenko

31.12.2017 10:40

developer   ~0009950

It might be that when portal is invisible in the mirror (the clipped part of it) it is marked as closed and then does not make it into the main view. The question is, why all other surfaces in the portalled area draw but not the mirror itself?
duzenko

duzenko

31.12.2017 12:21

developer   ~0009951

On a closer look it actually looks like two mirror surfaces, one of them (mirror bottom very thin invisible?) toggles another (main).
I think this needs to be resolved on the mapper's level.
The current engine logic is only do one subview of the same mirror material. All other are skipped until next frame.

R_MirrorRender:
    if ( stage->dynamicFrameCount == tr.frameCount ) {
        return;
    }

Attached screenshot with the blocking surface debug data.
It could originate from this surface in .proc file

/* surface 3 */ { "textures/washroom/mirror" /* numVerts = */ 4 /* numIndexes = */ 6
( -231 286 565 2.796875 1.9687502384 0 0 -1 ) ( -231 362 565 3.390625 1.9687502384 0 0 -1 ) ( -232 362 565 3.390625 1.9765627384 0 0 -1 )
( -232 286 565 2.796875 1.9765627384 0 0 -1 )
0 1 2 3 0 2
}
duzenko

duzenko

31.12.2017 12:21

developer  

Untitled.png (30,100 bytes)   
Untitled.png (30,100 bytes)   

Issue History

Date Modified Username Field Change
23.12.2017 08:07 stgatilov New Issue
23.12.2017 08:07 stgatilov Status new => assigned
23.12.2017 08:07 stgatilov Assigned To => duzenko
23.12.2017 08:08 stgatilov Additional Information Updated View Revisions
23.12.2017 08:09 stgatilov Steps to Reproduce Updated View Revisions
23.12.2017 08:10 stgatilov File Added: mirror_black.jpg
23.12.2017 08:10 stgatilov File Added: mirror_correct.jpg
23.12.2017 08:10 stgatilov File Added: mirror_black2.jpg
23.12.2017 08:10 stgatilov File Added: mirror_light_lacking.jpg
23.12.2017 08:11 stgatilov File Added: mirror_partially_black.jpg
23.12.2017 08:11 stgatilov File Added: Darkmod.cfg
23.12.2017 08:14 stgatilov Note Added: 0009867
23.12.2017 08:15 stgatilov Relationship added related to 0004699
23.12.2017 08:16 stgatilov Relationship added related to 0004632
23.12.2017 08:30 stgatilov Note Added: 0009868
31.12.2017 09:59 duzenko Note Added: 0009949
31.12.2017 09:59 duzenko Note Edited: 0009949 View Revisions
31.12.2017 10:40 duzenko Note Added: 0009950
31.12.2017 12:21 duzenko Note Added: 0009951
31.12.2017 12:21 duzenko File Added: Untitled.png
31.12.2017 12:22 duzenko Status assigned => resolved
31.12.2017 12:22 duzenko Fixed in Version => TDM 2.06
31.12.2017 12:22 duzenko Resolution open => no change required