View Issue Details

IDProjectCategoryView StatusLast Update
0004767DarkRadiantModelspublic09.01.2020 19:25
ReporterSpooks Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
OSWindowsOS Version7 
Product Version2.5.0 
Target Version2.6.0Fixed in Version2.6.0 
Summary0004767: Re-exporting .ase models screws up their normals
DescriptionExporting an .ase model from the "Export selected as model" DR option that has an .ase model func_static (alone or alongside brushes, patches, etc.) in it will cause the then-new exported model have its normals screwed up UNLESS the func_static's orientation aligns with the world orientation.
Steps To ReproduceCreate model, eg. models/darkmod/architecture/chimneys/chimney_metal_pipe_tall.ase

Make sure the func_static aligns with world directions -- Y is up, X is right in top orthoview.

Select it, Export selected as model, choose .ase.

Note that it looks fine in-game under light.

Now rotate the func_static 90 or 180° so that it no longer aligns to world. Re-export.

Reload models in-game, note how the normal has been reversed and now the model is dark when in light.
TagsNo tags attached.

Relationships

related to 0004750 resolvedgreebo Export Selected as .LWO Model: Exported models loose smooth shading after export. 

Activities

user81

02.04.2018 11:06

  ~0010346

Confirmed, its most notable on existing cylindrical models (pipes etc)
greebo

greebo

29.04.2018 03:54

administrator   ~0010410

Tried the above steps, but I can't reproduce this - maybe it's a combination of the export settings and the model plus the sequence.

Can you give me the settings you're using to export the model?
Also, can you confirm, that a DMAP run is not fixing the problem?
greebo

greebo

30.04.2018 04:14

administrator   ~0010422

Nevermind, I was testing with my intermediate WIP code, which had a different problem overshadowing this one. I can confirm it now, and I know what the reason is.
greebo

greebo

30.04.2018 05:06

administrator   ~0010423

Should be fixed in f026e57

Related Changesets

DarkRadiant: master f026e576

2018-04-30 06:13:25

greebo

Details Diff
Fix 0004767: Bad lighting when re-exporting models with a non-identity rotation transform. Affected Issues
0004767
mod - plugins/model/ModelExporterBase.h Diff File

Issue History

Date Modified Username Field Change
01.04.2018 11:59 Spooks New Issue
02.04.2018 11:06 user81 Note Added: 0010346
02.04.2018 11:08 user81 Relationship added related to 0004750
02.04.2018 11:08 user81 Assigned To => greebo
02.04.2018 11:08 user81 Status new => assigned
02.04.2018 16:18 greebo Assigned To greebo =>
02.04.2018 16:18 greebo Status assigned => confirmed
29.04.2018 03:54 greebo Note Added: 0010410
29.04.2018 03:54 greebo Status confirmed => feedback
30.04.2018 04:14 greebo Note Added: 0010422
30.04.2018 04:14 greebo Status feedback => confirmed
30.04.2018 04:14 greebo Assigned To => greebo
30.04.2018 04:14 greebo Status confirmed => assigned
30.04.2018 04:14 greebo Target Version => 2.6.0
30.04.2018 05:06 greebo Note Added: 0010423
30.04.2018 05:06 greebo Status assigned => resolved
30.04.2018 05:06 greebo Fixed in Version => 2.6.0
30.04.2018 05:06 greebo Resolution open => fixed
28.12.2019 11:00 greebo Status resolved => closed
09.01.2020 19:25 greebo Changeset attached => DarkRadiant master f026e576