View Issue Details

IDProjectCategoryView StatusLast Update
0004833The Dark ModTDM Updaterpublic11.05.2020 09:45
Reporterstgatilov Assigned Tostgatilov  
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004833: zsync-like differential updates (unofficial prototype)
DescriptionTry to implement zsync-style differential update and replace the current implementation with it.

Note: this change must NOT go into trunk.
Create it in a branch, ideally before 2.07 beta phase starts.
Additional InformationInternal discussion:
  http://forums.thedarkmod.com/topic/19486-tdm-update-single-algorithm-to-rule-them-all/
Standalone prototype:
  https://bitbucket.org/stgatilov/tdmsync/src/default/
TagsNo tags attached.

Relationships

has duplicate 0003710 closedtaaaki Modify tdm_update to cater for new server 
related to 0004005 new The updater sometimes finishes with the wrong % complete 
related to 0005250 assignedstgatilov New differential update and weekly builds 

Activities

stgatilov

stgatilov

25.06.2018 06:29

administrator   ~0010583

Removed 2.07 target to remove it from roadmap.
If I get time to do it before 2.07 --- great. If not --- well, ok =(
stgatilov

stgatilov

21.12.2018 16:07

administrator   ~0011008

As a matter of fact:
1) the tdmsync-based rough proto would soon go alpha-testing.
2) I have decribed a better approach without any complicated rsync-like algorithms here:
  http://forums.thedarkmod.com/topic/19486-tdm-update-single-algorithm-to-rule-them-all/#entry430804
stgatilov

stgatilov

20.01.2019 07:26

administrator   ~0011440

The tdmsync prototype work well for switching between 2.07 beta versions:
  http://forums.thedarkmod.com/topic/19789-prototype-of-time-travelling-tdmupdate/

I'm closing this issue as resolved, since the prototype is up and running.
The code is located in "tdmsync" branch.

For 2.08, the plan is to implement different approach closely tied to zip structure.

Issue History

Date Modified Username Field Change
11.06.2018 06:17 stgatilov New Issue
11.06.2018 06:17 stgatilov Status new => assigned
11.06.2018 06:17 stgatilov Assigned To => stgatilov
25.06.2018 06:28 stgatilov Target Version TDM 2.07 =>
25.06.2018 06:29 stgatilov Note Added: 0010583
21.12.2018 15:58 nbohr1more Relationship added has duplicate 0003710
21.12.2018 16:07 stgatilov Note Added: 0011008
28.12.2018 18:41 nbohr1more Relationship added related to 0004005
20.01.2019 07:24 stgatilov Target Version => TDM 2.07
20.01.2019 07:26 stgatilov Note Added: 0011440
20.01.2019 07:26 stgatilov Status assigned => resolved
20.01.2019 07:26 stgatilov Fixed in Version => TDM 2.07
20.01.2019 07:26 stgatilov Resolution open => fixed
11.05.2020 09:45 stgatilov Relationship added related to 0005250