View Issue Details

IDProjectCategoryView StatusLast Update
0004862DarkRadiantRendererpublic09.11.2020 03:36
ReporterSpooks Assigned To 
PrioritynormalSeveritynormalReproducibilityrandom
Status closedResolutionunable to reproduce 
OSWindowsOS Version7 
Product Version2.6.0 
Summary0004862: Phantom Models Left-Over in 3D Viewport
DescriptionSometimes, a func_static with a model will leave a phantom model in the 3D viewport. I've noticed two circumstances in which this happens.

Undoing/Redoing a func_static changing its "model" spawnarg, and then deleting that func_static, will leave a phantom model. This model is not selectable and will not go away until DR is restarted.

Changing the "model" spawnarg of the func_static, undoing, then changing it again. The phantom model will stick to the func_static origin, and can be deleted if the func_static itself gets deleted. Steps to reproduce this are below, as the first circumstance is way too random to reproduce reliably.
Steps To ReproduceMake func_static, assign model.
Change the model to something else.
Undo.
Change model to something else, again.
The last model will not get removed from the 3D viewport, and the new model will superimpose on top of it. No amount of changing models will remove the phantom model, only deleting the func_static itself.
Additional InformationNote that this is a purely visual glitch with the viewports (I've not really payed attention if orthoviews are affected, tbh). No actual, doubled entities get saved to the map (as far as I'm aware) or show up wrong in-game.
TagsNo tags attached.

Relationships

related to 0005385 resolvedgreebo Phantom Model Left Over in Model Selector Window 

Activities

greebo

greebo

27.08.2018 12:10

administrator   ~0010742

I tried to repro this in 2.6.0 as well as in latest Git, but failed to reproduce that. I followed the steps exactly, at least I think I did.

Can you reliably repro this on your end? Maybe I'm missing something.
Spooks

Spooks

08.11.2020 19:41

reporter   ~0012870

I've not used DR as often since reporting this bug but I don't recall seeing it manifest recently. Whatever the mysterious cause must've vanished just as mysteriously. I'm closing this, hopefully for good.
Spooks

Spooks

08.11.2020 19:43

reporter   ~0012871

...Except that by posting that note I just screwed myself over on assigning the proper resolution by bumping the status back to new. Whoops.

Issue History

Date Modified Username Field Change
10.07.2018 22:50 Spooks New Issue
12.07.2018 04:02 greebo Status new => acknowledged
27.08.2018 12:10 greebo Note Added: 0010742
27.08.2018 12:10 greebo Status acknowledged => feedback
08.11.2020 19:41 Spooks Note Added: 0012870
08.11.2020 19:41 Spooks Status feedback => new
08.11.2020 19:43 Spooks Note Added: 0012871
08.11.2020 19:58 Spooks Issue cloned: 0005385
08.11.2020 19:58 Spooks Relationship added related to 0005385
09.11.2020 03:36 greebo Status new => closed
09.11.2020 03:36 greebo Resolution open => unable to reproduce