View Issue Details

IDProjectCategoryView StatusLast Update
0005385DarkRadiantRendererpublic14.11.2020 14:26
ReporterSpooks Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilitysometimes
Status resolvedResolutionduplicate 
OSWindowsOS Version7 
Product Version2.6.0 
Fixed in Version2.9.0 
Summary0005385: Phantom Model Left Over in Model Selector Window
DescriptionThis is a bug that I've encountered for as long as the similarly named one about models in the main program 3D window, hence I'm tagging it as 2.6.0. Incredibly, I've forgotten to report it for this long, considering it's a real eye-strain sometimes. I have just checked on 2.9.0pre2 and I managed to reproduce it very quickly.

A previously selected model in the "Choose a Model" dialogue can just stay in the 3D preview while new models are being selected, obscuring them. It remains scaled correctly, meaning smaller models get obscured more. A restart is needed to fix this.
Steps To ReproduceIt is hard to tell how exactly this is reproducible. I'm fairly sure it involves undoing/redoing and clicking the "Choose model..." button. I've gotten it to manifest by:

Creating a couple of func_statics with different models.
Undoing/redoing and clicking "Choose model..." on either of them to change to a new model/check on the 3D preview window until the bug pops out.
TagsNo tags attached.

Relationships

duplicate of 0005402 resolvedgreebo Model browser renders 3D previews for past models, overlaps current selection 
related to 0004862 closed Phantom Models Left-Over in 3D Viewport 

Activities

Spooks

Spooks

08.11.2020 19:58

reporter  

example of bug.jpg (216,610 bytes)   
example of bug.jpg (216,610 bytes)   
Bikerdude

Bikerdude

08.11.2020 20:58

reporter   ~0012877

Confirmed, but I think this has been a problem for a while, since version 2.6 or earlier.
Bikerdude

Bikerdude

14.11.2020 14:26

reporter   ~0012934

Nice one Greebo,

Issue History

Date Modified Username Field Change
08.11.2020 19:58 Spooks New Issue
08.11.2020 19:58 Spooks File Added: example of bug.jpg
08.11.2020 19:58 Spooks Issue generated from: 0004862
08.11.2020 19:58 Spooks Relationship added related to 0004862
08.11.2020 20:58 Bikerdude Note Added: 0012877
13.11.2020 19:17 greebo Relationship added related to 0005402
14.11.2020 06:03 greebo Relationship replaced duplicate of 0005402
14.11.2020 08:01 greebo Status new => confirmed
14.11.2020 13:55 greebo Assigned To => greebo
14.11.2020 13:55 greebo Status confirmed => resolved
14.11.2020 13:55 greebo Resolution open => duplicate
14.11.2020 13:55 greebo Fixed in Version => 2.9.0
14.11.2020 14:26 Bikerdude Note Added: 0012934