View Issue Details

IDProjectCategoryView StatusLast Update
0004950The Dark ModObjectivespublic08.01.2019 17:29
Reporternbohr1more Assigned Tonbohr1more  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 2.06 
Target VersionTDM 2.07Fixed in VersionTDM 2.07 
Summary0004950: All scores set to Zero when 100% loot is collected in some missions
DescriptionWhen completing "Closemouthed Shadows" with 100% loot collected,
the mission completion screen renders Zero for all statistics.
Steps To Reproduce1) Install Closemouthed Shadows
2) Finish mission with all loot
3) Note that the Mission Complete screen has all Zeros
Additional InformationSTiFU identified the main cause of the issue:

Forum discussion: http://forums.thedarkmod.com/topic/19770-devs-207-is-branched-out/page-4#entry432709

("Root cause" is still under investigation.)
TagsNo tags attached.

Relationships

child of 0004222 assignedgrayman Might be a Mission Stats problem with registering alerts 

Activities

nbohr1more

nbohr1more

08.01.2019 04:56

developer   ~0011256

Last edited: 08.01.2019 04:58

View 2 revisions

Proposed fix:

MissionData.cpp

// under HandleMainMenuCommands

if (!gui->GetStateBool("ingame") && gameLocal.m_MissionResult != MISSION_COMPLETE )

//Prevents redundant Objectives Screen from rendering and clearing objectives data

Rev 7903 trunk

STiFU

STiFU

08.01.2019 08:00

developer   ~0011257

To give some more details:
-Behavior is independent of collected loot and stealth score
-It is a mission specific issue: It doesn't happen on A New Job for instance.
-The problem is that the game tries to open the objectives screen which clears all mission data. It is unknown at this point, why it wants to open that screen. Somewhere, the gui cmd objective_open_request is generated.
STiFU

STiFU

08.01.2019 17:13

developer   ~0011258

Got it. Pressing "Start Mission" in the objectives screen was missing a reset of the mainmenu gui state. Fixed in rev. 15532

Issue History

Date Modified Username Field Change
08.01.2019 04:54 nbohr1more New Issue
08.01.2019 04:54 nbohr1more Status new => assigned
08.01.2019 04:54 nbohr1more Assigned To => nbohr1more
08.01.2019 04:55 nbohr1more Relationship added child of 0004222
08.01.2019 04:56 nbohr1more Note Added: 0011256
08.01.2019 04:57 nbohr1more Status assigned => feedback
08.01.2019 04:58 nbohr1more Note Edited: 0011256 View Revisions
08.01.2019 08:00 STiFU Note Added: 0011257
08.01.2019 08:00 STiFU Additional Information Updated View Revisions
08.01.2019 14:07 nbohr1more Additional Information Updated View Revisions
08.01.2019 14:59 nbohr1more Additional Information Updated View Revisions
08.01.2019 17:13 STiFU Note Added: 0011258
08.01.2019 17:29 STiFU Status feedback => resolved
08.01.2019 17:29 STiFU Resolution open => fixed
08.01.2019 17:29 STiFU Fixed in Version => TDM 2.07