View Issue Details

IDProjectCategoryView StatusLast Update
0005062The Dark ModTDM Updaterpublic16.11.2019 05:38
Reporterstgatilov Assigned Tostgatilov  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.07 
Target VersionTDM 2.08Fixed in Version 
Summary0005062: Disable VCRedist installation step in updater
DescriptionNow we have returned back to full static linking, so redistributable package is not necessary.
This fucking nightmare is over.

Created this task to track removal of VCRedist installation step in the updater.
TagsNo tags attached.

Relationships

related to 0004875 resolvedstgatilov Update and Improve VCRedist installation 
related to 0004595 resolvedstgatilov Install VC++ redistributable in tdm_update 

Activities

stgatilov

stgatilov

16.11.2019 05:25

developer   ~0011867

The switch to static runtime was done in 3rdparty_4822 branch due to 0004822:
  http://forums.thedarkmod.com/index.php?/topic/19840-208-third-party-libraries-overhaul/&do=findComment&comment=436439
stgatilov

stgatilov

16.11.2019 05:38

developer   ~0011868

Done in svn rev 8396.

The code is still there, but all commented out.
Checked that it does not try to install VCRedist and does not show any messages about it.

Issue History

Date Modified Username Field Change
16.11.2019 05:21 stgatilov New Issue
16.11.2019 05:21 stgatilov Status new => assigned
16.11.2019 05:21 stgatilov Assigned To => stgatilov
16.11.2019 05:21 stgatilov Relationship added related to 0004875
16.11.2019 05:22 stgatilov Relationship added related to 0004595
16.11.2019 05:25 stgatilov Note Added: 0011867
16.11.2019 05:38 stgatilov Note Added: 0011868
16.11.2019 05:38 stgatilov Status assigned => resolved
16.11.2019 05:38 stgatilov Resolution open => fixed