View Issue Details

IDProjectCategoryView StatusLast Update
0005114DarkRadiantGUIpublic09.01.2020 19:25
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.7.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0005114: 2.7pre3: Model selection: materials/verts/polys display always refers to previously selected model
DescriptionExclusive to pre3 is that whenever I click on a new model in 'Create model' or 'Choose model', part of the GUI in the lower left corner displays the stats of the previously selected model.
I.e. if I highlight a painting with 50 polys, then highlight a stagecoach with 9467 polys, the stagecoach is stated to have 50 polys.

This affects:
Material list
Total vertices, Total polys
Material surfaces #

But not:
Model name
Skin name
Steps To ReproduceSearch for 'coil'. This brings you to 3 ropes: the first and last are low poly (318) and have 2 materials, while the middle one is high poly (2591) and has 1 material. This isn't accurately reflected when arrow-keying down the list.
TagsNo tags attached.

Relationships

related to 0005094 resolvedgreebo Choose Skin dialog will crash in 2.7.0pre2 

Activities

greebo

greebo

07.01.2020 18:56

administrator   ~0012115

Confirmed, this is caused by the fix against the GL context problems as in 0005094.
greebo

greebo

07.01.2020 19:24

administrator   ~0012116

Nice find, this should be fixed in 6a41c6d6e

Related Changesets

DarkRadiant: master 6a41c6d6

2020-01-07 20:21:47

greebo

Details Diff
Fix 0005114, which is a regression caused by the lazy-loading introduced to fix the GL context issues in the skin selector preview. Since the model node is not immediately loaded when calling ModelPreview::setModel(), the client code needs to rely on the newly exposed signal_ModelLoaded. Affected Issues
0005114
mod - libs/wxutil/preview/ModelPreview.cpp Diff File
mod - libs/wxutil/preview/ModelPreview.h Diff File
mod - radiant/ui/modelselector/ModelSelector.cpp Diff File
mod - radiant/ui/modelselector/ModelSelector.h Diff File

Issue History

Date Modified Username Field Change
07.01.2020 09:33 Dragofer New Issue
07.01.2020 09:35 Dragofer Summary 2.7pre3: Model selection: materials/verts/polys display is always 1 click behind => 2.7pre3: Model selection: materials/verts/polys display always refers to previously selected model
07.01.2020 18:56 greebo Assigned To => greebo
07.01.2020 18:56 greebo Status new => confirmed
07.01.2020 18:56 greebo Note Added: 0012115
07.01.2020 18:56 greebo Relationship added related to 0005094
07.01.2020 19:18 greebo Product Version => 2.7.0
07.01.2020 19:18 greebo Target Version => 2.7.0
07.01.2020 19:18 greebo Assigned To greebo =>
07.01.2020 19:18 greebo Assigned To => greebo
07.01.2020 19:18 greebo Status confirmed => assigned
07.01.2020 19:24 greebo Status assigned => resolved
07.01.2020 19:24 greebo Resolution open => fixed
07.01.2020 19:24 greebo Fixed in Version => 2.7.0
07.01.2020 19:24 greebo Note Added: 0012116
09.01.2020 19:25 greebo Changeset attached => DarkRadiant master 6a41c6d6