View Issue Details

IDProjectCategoryView StatusLast Update
0005116DarkRadiantModelspublic18.11.2020 08:25
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.6.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0005116: Export patches: .ase has too many verts
DescriptionWhile re-exporting models in DR has been working fine, exporting patches as an .ase creates a model that has too many verts: so i.e. a cylinder with 32 polys will have 96 verts (each poly has 3 own verts). This doesn't seem to have any effect on ingame rendering.

The excess of verts persists when I import the model into Blender 2.79b. In the above example with the cylinder, I'm able to remove 64 verts when removing doubles.
Steps To Reproduce1) Create a cylinder patch, give it ship_hull_medium as a texture and change subdivisions to 4 horizontal and 1 vertical. This shape has 34 vertices and 32 polys.
2) Select the cylinder and 'Export selected as model' with these settings

Output Format: .ase
Center objects around origin
Skip surfaces textured with caulk

The model has 3 verts for every 1 poly.
Additional InformationTested & confirmed in 2.6, 2.7pre2, 2.7pre3
The attached archive and image also contains .lwo exports of a patch, as those are also misbehaving. (0005115)
TagsNo tags attached.

Relationships

related to 0005115 resolvedgreebo Export patches: .lwo loses smooth shading 

Activities

Dragofer

Dragofer

07.01.2020 10:09

developer  

export_patch.pk4 (506,808 bytes)
export_patch_ase.png (114,055 bytes)   
export_patch_ase.png (114,055 bytes)   
export_patch_lwo.png (114,024 bytes)   
export_patch_lwo.png (114,024 bytes)   
Bikerdude

Bikerdude

01.05.2020 12:49

reporter   ~0012444

@Dragofer, might be worth testing this in 2.08 pre5 to see if the issue is still present
Bikerdude

Bikerdude

17.11.2020 15:36

reporter   ~0012965

Is this related to 0005383?
Dragofer

Dragofer

17.11.2020 18:40

developer   ~0012969

Not really, .ase meshes really do contain too much vertex data. This gets revealed when importing into Blender, where removing doubles gets rid of a ton of vertices (i.e. 96 gets reduced to 32).

But I think TDM has some kind of inbuilt removal of vertex doubles for .ase's, so they still look smooth ingame.
Bikerdude

Bikerdude

17.11.2020 19:07

reporter   ~0012971

Ok will test it in 2.9pre3 just to see if its still present.
Bikerdude

Bikerdude

17.11.2020 21:02

reporter   ~0012972

Last edited: 17.11.2020 21:03

View 2 revisions

I have tested this on a.ASE exported from 2.9pre3 and it looks to be fixed, as the total verts in Blender 2.76 matched what DR is showing (see attached)
blender2.76.png (10,144 bytes)   
blender2.76.png (10,144 bytes)   
unknown.png (26,975 bytes)   
unknown.png (26,975 bytes)   
greebo

greebo

18.11.2020 02:50

administrator   ~0012973

Yes, this should have been solved along with 0005115
Bikerdude

Bikerdude

18.11.2020 08:25

reporter   ~0012976

Last edited: 18.11.2020 08:25

View 2 revisions

Nice work Greebo.

Issue History

Date Modified Username Field Change
07.01.2020 10:09 Dragofer New Issue
07.01.2020 10:09 Dragofer File Added: export_patch.pk4
07.01.2020 10:09 Dragofer File Added: export_patch_ase.png
07.01.2020 10:09 Dragofer File Added: export_patch_lwo.png
01.05.2020 12:49 Bikerdude Note Added: 0012444
17.11.2020 15:36 Bikerdude Note Added: 0012965
17.11.2020 18:40 Dragofer Note Added: 0012969
17.11.2020 19:07 Bikerdude Note Added: 0012971
17.11.2020 21:02 Bikerdude Note Added: 0012972
17.11.2020 21:02 Bikerdude File Added: blender2.76.png
17.11.2020 21:02 Bikerdude File Added: unknown.png
17.11.2020 21:03 Bikerdude Note Edited: 0012972 View Revisions
18.11.2020 02:48 greebo Relationship added related to 0005115
18.11.2020 02:50 greebo Assigned To => greebo
18.11.2020 02:50 greebo Status new => assigned
18.11.2020 02:50 greebo Target Version => 2.9.0
18.11.2020 02:50 greebo Status assigned => resolved
18.11.2020 02:50 greebo Resolution open => fixed
18.11.2020 02:50 greebo Fixed in Version => 2.9.0
18.11.2020 02:50 greebo Note Added: 0012973
18.11.2020 08:25 Bikerdude Note Added: 0012976
18.11.2020 08:25 Bikerdude Note Edited: 0012976 View Revisions