View Issue Details

IDProjectCategoryView StatusLast Update
0005134DarkRadiantMap Editingpublic21.04.2020 04:15
ReporterDragofer Assigned Togreebo  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.7.0 
Fixed in Version2.8.0 
Summary0005134: 'Reload models' reveals hidden models
DescriptionIf the mapper has hidden models - by selecting them & pressing h - and uses 'Reload models' all hidden models become visible. They cannot be selected.
Pressing shift-h to unhide everything will make them selectable again.

The models 'unhidden' by this bug still respect layer visibilities.
Steps To Reproduce1) Create a model: stagecoach.lwo
2) With the stagecoach selected, press h
3) File -> Reload models, or Create model -> Reload models: the stagecoach becomes visible, but can't be selected.
4) Press shift h to unhide everything. The stagecoach becomes selectable again and seems to behave normally from now on.
TagsNo tags attached.

Relationships

related to 0004141 closedgreebo Reload models unhides hidden models 
related to 0002709 closedgreebo Hidden models are visible but not selectible after the Reload models command 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master e8021a89

2020-04-21 04:14:37

greebo

Details Diff
0005134: Fix 'Reload models' revealing hidden models.
This time around, copy *all* visibility flags from the parent node to the model node after refreshing
Affected Issues
0005134
mod - libs/scenelib.h Diff File
mod - radiant/entity/ModelKey.cpp Diff File

Issue History

Date Modified Username Field Change
29.01.2020 14:51 Dragofer New Issue
30.01.2020 03:32 greebo Status new => acknowledged
20.04.2020 18:04 greebo Status acknowledged => confirmed
21.04.2020 03:59 greebo Relationship added related to 0004141
21.04.2020 04:08 greebo Relationship added related to 0002709
21.04.2020 04:14 greebo Changeset attached => DarkRadiant master e8021a89
21.04.2020 04:14 greebo Assigned To => greebo
21.04.2020 04:14 greebo Status confirmed => assigned
21.04.2020 04:15 greebo Status assigned => resolved
21.04.2020 04:15 greebo Resolution open => fixed
21.04.2020 04:15 greebo Fixed in Version => 2.8.0