View Issue Details

IDProjectCategoryView StatusLast Update
0005226DarkRadiantGUIpublic27.04.2020 07:06
ReporterDragofer Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.8.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0005226: Feature: "Select Parent Entities"
DescriptionAs per 0005122:

To complement "Selection by Filter", which selects individual members of groups such as func_statics, a method to expand the selection to the whole group would come in handy for purposes of inverting + hiding the selection to show nothing but the groups containing these members.

A shortcut would be handy for this as well, for performing something like this swiftly:
"Select by Filter" -> Nodraw Textures -> [shortcut] + i + h (= Select Parent Entities -> Invert -> Hide)
Or maybe even better would be a place under "Select/Deselect by Filter" on the drop-down context menu, as these functions may often get used together?

Another name could be "Expand Selection to Parents", to give a better idea of what it does.
TagsNo tags attached.

Relationships

related to 0005122 resolvedgreebo Feature: Selection by Filter 

Activities

greebo

greebo

25.04.2020 11:12

administrator   ~0012403

I named it "Select Parent Entities" because it's basically the counter-part of the already existing "Select Children" command
select_parent_entities.png (36,005 bytes)   
select_parent_entities.png (36,005 bytes)   
Dragofer

Dragofer

25.04.2020 14:42

developer   ~0012404

Thanks! I've been thinking it might make sense to integrate this into the Invert Selection command. At the moment it can feel unintuitive that sometimes it looks like you've selected something, but in reality you've only selected a child, so when you press I to invert it's still selected. 'Select by Filter' is the prime example of that.

Maybe the current Invert Selection behaviour can then be kept with the hotkey ctrl + i, and named something like 'Invert Selection (Children)'.
greebo

greebo

25.04.2020 14:48

administrator   ~0012405

I'm hesitant to change the Invert selection command to accomodate a newly added, but competely optional feature.

Can you describe the undesired behaviour, what's the problem? Which elements stay selected after inverting the selection?

Related Changesets

DarkRadiant: master a606a621

2020-04-25 11:09:52

greebo

Details Diff
0005226: Add "Select Parent Entities" command to select the parent entity of any selected child primitive (deselecting the children). Affected Issues
0005226
mod - install/input.xml Diff File
mod - install/menu.xml Diff File
mod - radiant/selection/algorithm/General.cpp Diff File
mod - radiant/selection/algorithm/Group.cpp Diff File
mod - radiant/selection/algorithm/Group.h Diff File

Issue History

Date Modified Username Field Change
25.04.2020 09:48 Dragofer New Issue
25.04.2020 09:48 Dragofer Relationship added related to 0005122
25.04.2020 09:49 Dragofer Description Updated View Revisions
25.04.2020 09:54 greebo Status new => acknowledged
25.04.2020 11:08 greebo Assigned To => greebo
25.04.2020 11:08 greebo Status acknowledged => assigned
25.04.2020 11:08 greebo Target Version => 2.8.0
25.04.2020 11:10 greebo Changeset attached => DarkRadiant master a606a621
25.04.2020 11:11 greebo Status assigned => resolved
25.04.2020 11:11 greebo Resolution open => fixed
25.04.2020 11:11 greebo Fixed in Version => 2.8.0
25.04.2020 11:12 greebo Note Added: 0012403
25.04.2020 11:12 greebo File Added: select_parent_entities.png
25.04.2020 14:42 Dragofer Status resolved => feedback
25.04.2020 14:42 Dragofer Resolution fixed => reopened
25.04.2020 14:42 Dragofer Note Added: 0012404
25.04.2020 14:48 greebo Note Added: 0012405
27.04.2020 07:06 Dragofer Status feedback => resolved
27.04.2020 07:06 Dragofer Resolution reopened => fixed