View Issue Details

IDProjectCategoryView StatusLast Update
0005290DarkRadiantGUIpublic19.11.2020 03:34
ReporterDragofer Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.8.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0005290: 'Delete property' is greyed out when multiple properties are selected
DescriptionAs per title, having multiple properties selected in the entity inspector will cause the 'Delete property' option in the right-click menu to become greyed out. The easy workaround is to use 'Cut' instead, but that overwrites whatever I may have in my copy/paste storage.
TagsNo tags attached.

Relationships

related to 0005421 resolvedgreebo Deleting multiple properties adds multiple events to undo queue 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 61f9d0f6

2020-09-20 08:40:06

greebo

Details Diff
0005290: Fix "Delete Property" being greyed out for more than one spawnarg selected in the EntityInspector.
Streamline the logic for delete and cut key values a bit, since they are pretty similar.
Affected Issues
0005290
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

Issue History

Date Modified Username Field Change
10.07.2020 07:59 Dragofer New Issue
20.09.2020 08:16 greebo Status new => confirmed
20.09.2020 08:16 greebo Target Version => 2.9.0
20.09.2020 08:40 greebo Changeset attached => DarkRadiant master 61f9d0f6
20.09.2020 08:40 greebo Assigned To => greebo
20.09.2020 08:40 greebo Status confirmed => assigned
20.09.2020 08:40 greebo Status assigned => resolved
20.09.2020 08:40 greebo Resolution open => fixed
20.09.2020 08:40 greebo Fixed in Version => 2.9.0
19.11.2020 03:34 greebo Relationship added related to 0005421