View Issue Details

IDProjectCategoryView StatusLast Update
0005421DarkRadiantGUIpublic19.11.2020 03:35
ReporterDragofer Assigned Togreebo  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.8.0 
Fixed in Version2.9.0 
Summary0005421: Deleting multiple properties adds multiple events to undo queue
DescriptionIt's possible to highlight multiple spawnargs in the entity inspector and right-click > cut (or now also delete) to delete them all in one go. However, pressing undo only restores one property at a time.

This makes it more difficult to get back to the state before the properties were deleted, since the mapper needs to monitor the entity inspector to ensure all properties have been restored.
Steps To Reproduce1) Create an entity, i.e. a stagecoach model.
2) Select multiple spawnargs in the entity inspector and right-click > cut or delete.
3) Press ctrl - z. Only one spawnarg has been restored.
Additional InformationI haven't had a chance to test or try 2.9 yet so it's possible you've already fixed this while resolving:
0005290: [GUI] 'Delete property' is greyed out when multiple properties are selected
TagsNo tags attached.

Relationships

related to 0005290 resolvedgreebo 'Delete property' is greyed out when multiple properties are selected 

Activities

greebo

greebo

19.11.2020 03:35

administrator   ~0012986

Yes, I just checked, this issue is not occurring in 2.9.0 anymore.

Issue History

Date Modified Username Field Change
18.11.2020 13:07 Dragofer New Issue
18.11.2020 13:09 Dragofer Description Updated View Revisions
19.11.2020 03:34 greebo Relationship added related to 0005290
19.11.2020 03:35 greebo Assigned To => greebo
19.11.2020 03:35 greebo Status new => resolved
19.11.2020 03:35 greebo Resolution open => no change required
19.11.2020 03:35 greebo Fixed in Version => 2.9.0
19.11.2020 03:35 greebo Note Added: 0012986