View Issue Details

IDProjectCategoryView StatusLast Update
0005365The Dark ModGraphicspublic07.11.2020 17:28
ReporterAluminumHaste Assigned Toduzenko  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionno change required 
Product VersionTDM 2.08 
Target VersionTDM 2.09Fixed in VersionTDM 2.08 
Summary0005365: Portal Sky has been partially broken since 2.05
DescriptionThread: https://forums.thedarkmod.com/index.php?/topic/20605-skybox-texture-not-working-or-gets-broken-cant-fix/&tab=comments#comment-452463

Issue is that unless a brush touches another brush or is part of a brush touching the void, portal_sky renders nothing.
In 2.08 and SVN: https://forums.thedarkmod.com/uploads/monthly_2020_10/darkmod_2020-10-23_09_24_47.jpg.dd97cfb0afdea42f326b6cc00e61ee78.jpg

In 2.04: https://forums.thedarkmod.com/uploads/monthly_2020_10/darkmod_2020-10-23_13_15_09.jpg.12e27f3e6a41cc4c922b03c2e24114ad.jpg

Test Map below.
There were some changes for 2.05 that dealt directly with skyboxes: "duzenko Optimize Skybox rendering by changing it's render order (takes better advantage of hierarchical-z)"
Steps To ReproduceI've attached a small test map.
TagsNo tags attached.

Relationships

related to 0004635 new New portalSky method is see-through like caulk skies... which isn't always desirable 
child of 0004414 resolvedduzenko See if skybox can be rendered faster 

Activities

AluminumHaste

AluminumHaste

23.10.2020 19:35

developer   ~0012821

Uploaded better example map
skytest.zip (47,193 bytes)
AluminumHaste

AluminumHaste

23.10.2020 20:02

developer   ~0012822

Works with g_enablePortalSky 1
duzenko

duzenko

24.10.2020 07:16

developer   ~0012823

Last edited: 24.10.2020 07:18

View 2 revisions

The idea behind the sky optimization is, there's nothing behind it
The sky in your test map actually renders, but at infinity and get overdrawn by the room floor afterwards
Use r_subviewOnly 1 to check
Do you want something like Prey 2005 portals? https://youtu.be/x8R1XCojhdI?t=4486
AluminumHaste

AluminumHaste

24.10.2020 12:12

developer   ~0012824

Last edited: 24.10.2020 12:13

View 2 revisions

In my map I have a hole in the cave ceiling that moonlight streams in from.
In the attached picture you can see it circled in red.

This worked just fine up until 2.05, don't know why I didn't notice it not working before this though.

EDIT: Also yes, it would be something I was going to use in this map also for a portal effect.
holeincave.jpg (586,783 bytes)
duzenko

duzenko

24.10.2020 18:31

developer   ~0012825

I think as long as nothing overlaps the sky from behind you should be good
If you do have something at the back then we can discuss this as a new feature but it's not a skybox by definition
AluminumHaste

AluminumHaste

25.10.2020 13:10

developer   ~0012826

In the picture I posted, you can see circled in red, that the skybox I made is floating in the map, it's not touching an outside wall.

I recorded a quick video in game: https://www.youtube.com/watch?v=_Blr2LBcvC8
Judith

Judith

25.10.2020 17:32

reporter   ~0012829

To make a proper skybox, you realign the borders of that big room so the other cube with skyportal material has its walls next to the void, with nothing else between.
AluminumHaste

AluminumHaste

25.10.2020 18:13

developer   ~0012830

@Judith that's how it works now, but up until v2.05 it didn't work that way, you could have a skyportal on any face anywhere in your map and get the desired effect.
Judith

Judith

25.10.2020 18:25

reporter   ~0012831

Then it was like some other sort of a camera, I guess. Current skybox implementation is "by-the-book", and in line with how it works in other engines with subtractive geometry, where skybox was basically rendered instead of the void, and the skyportal was mostly just an invisible material that let you show it.

IMO the feature you want should be made separate as another camera entity type.
duzenko

duzenko

26.10.2020 15:07

developer   ~0012833

To reiterate, I think what you want should be filed under feature request rather than bugs
But then again, if you just need a sky, it will be easier for everyone if you just slam it against the void
AluminumHaste

AluminumHaste

27.10.2020 12:51

developer   ~0012845

Okay, I'll do my best to modify the map to accommodate the optimizations
AluminumHaste

AluminumHaste

27.10.2020 12:57

developer   ~0012846

Closing bug report as it is working as intended.

Issue History

Date Modified Username Field Change
23.10.2020 17:24 AluminumHaste New Issue
23.10.2020 17:24 AluminumHaste File Added: skytest.zip
23.10.2020 18:18 AluminumHaste Assigned To => duzenko
23.10.2020 18:18 AluminumHaste Status new => assigned
23.10.2020 19:34 AluminumHaste File Deleted: skytest.zip
23.10.2020 19:35 AluminumHaste Note Added: 0012821
23.10.2020 19:35 AluminumHaste File Added: skytest.zip
23.10.2020 20:02 AluminumHaste Note Added: 0012822
23.10.2020 20:02 AluminumHaste File Added: darkmod_2020-10-23_15.58.04.jpg
24.10.2020 03:27 nbohr1more Relationship added child of 0004414
24.10.2020 07:16 duzenko Note Added: 0012823
24.10.2020 07:18 duzenko Note Edited: 0012823 View Revisions
24.10.2020 12:12 AluminumHaste Note Added: 0012824
24.10.2020 12:12 AluminumHaste File Added: holeincave.jpg
24.10.2020 12:13 AluminumHaste Note Edited: 0012824 View Revisions
24.10.2020 18:31 duzenko Note Added: 0012825
25.10.2020 13:10 AluminumHaste Note Added: 0012826
25.10.2020 17:32 Judith Note Added: 0012829
25.10.2020 18:13 AluminumHaste Note Added: 0012830
25.10.2020 18:25 Judith Note Added: 0012831
26.10.2020 15:07 duzenko Note Added: 0012833
27.10.2020 12:51 AluminumHaste Note Added: 0012845
27.10.2020 12:57 AluminumHaste Status assigned => closed
27.10.2020 12:57 AluminumHaste Resolution open => no change required
27.10.2020 12:57 AluminumHaste Fixed in Version => TDM 2.08
27.10.2020 12:57 AluminumHaste Note Added: 0012846
07.11.2020 17:28 VanishedOne Relationship added related to 0004635