View Issue Details

IDProjectCategoryView StatusLast Update
0005391DarkRadiantGUIpublic13.11.2020 16:44
ReporterBikerdude Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version2.8.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0005391: On/off Selection issue with layers window
Description- open any map
- open the layers window
- press LMB slowly but repeatedly (0.5 seconds or lower between clicks)

half of the time the layer will stay selected.
Additional InformationThis is related to https://bugs.thedarkmod.com/view.php?id=5097
TagsNo tags attached.

Relationships

related to 0005097 resolvedgreebo Layer toggle controls can get out of sync (showing wrong icons) 

Activities

Bikerdude

Bikerdude

10.11.2020 09:40

reporter   ~0012886

Is related to 0005097
greebo

greebo

13.11.2020 16:39

administrator   ~0012902

Found the source of this issue: when clicking repeatedly and fast enough, the wxToggleButton is receiving double-click events, which are then translated to toggle events - clicking three times fast in a row will issue 4 toggle events. Confirmed at least in the wxMSW implementation.
Bikerdude

Bikerdude

13.11.2020 16:43

reporter   ~0012903

Nice work Greebo!

Related Changesets

DarkRadiant: 2.9.0 ca0de917

2020-11-13 16:44:19

greebo

Details Diff
0005391: Fix layer control dialog toggle buttons receiving additional wxEVT_TOGGLEBUTTON events due to double clicks (Windows only) Affected Issues
0005391
mod - radiant/ui/layers/LayerControl.cpp Diff File

Issue History

Date Modified Username Field Change
09.11.2020 12:52 Bikerdude New Issue
09.11.2020 14:22 Dragofer Relationship added related to 0005097
10.11.2020 09:40 Bikerdude Note Added: 0012886
13.11.2020 16:39 greebo Status new => confirmed
13.11.2020 16:39 greebo Note Added: 0012902
13.11.2020 16:39 greebo Target Version => 2.9.0
13.11.2020 16:40 greebo Assigned To => greebo
13.11.2020 16:40 greebo Status confirmed => assigned
13.11.2020 16:43 Bikerdude Note Added: 0012903
13.11.2020 16:44 greebo Changeset attached => DarkRadiant 2.9.0 ca0de917
13.11.2020 16:44 greebo Status assigned => resolved
13.11.2020 16:44 greebo Resolution open => fixed
13.11.2020 16:44 greebo Fixed in Version => 2.9.0