View Issue Details

IDProjectCategoryView StatusLast Update
0005408DarkRadiantDesign/Codingpublic29.10.2021 17:47
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.8.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0005408: All scene graphs connect to the same undo system, causing interference
DescriptionIn Issue 0005402 interference of the two scenegraphs in the ModelPreview and the rest of the map can be observed, caused by the Nodes connecting to the same global undo system. The Undo System or the change tracking needs to be able to distinguish between the scenes, similar to the LayerManager refactoring done in the past.
TagsNo tags attached.

Relationships

related to 0005402 closedgreebo Model browser renders 3D previews for past models, overlaps current selection 
related to 0005505 resolvedgreebo Selecting a prefab in Prefab Chooser counts as a saveable change 

Activities

greebo

greebo

26.06.2021 18:10

administrator   ~0014127

As of 2.13.0pre3, this is actually causing crashes when undoing a createEntity operation.
MirceaKitsune

MirceaKitsune

29.06.2021 12:45

reporter   ~0014134

This might explain why in some cases, if I select a surface (not sure if entire brush too) and change its texture then use undo, the texture change will sometimes be ignored and the undo system will skip it and proceed to undo only other changes before that. It's a bug I forgot to report separately but should wait for this fix to reach Git before I do.

Related Changesets

DarkRadiant: master d13fd481

2021-06-26 18:16:07

greebo

Details Diff
0005408: Work around running into a crash due to the ModelPreview scenegraph pushing undoables to the global undo operation stack.
If the calling code of EntityClassChooser::chooseEntityClass() creates an UndoableCommand before the call, all manipulations of the ModelPreview scene go to that active UndoOperation. When trying to undo that, the nodes in question have long been deleted and the restoreSnapshot method provokes a crash.
Affected Issues
0005408
mod - include/version.h Diff File
mod - radiant/ui/ortho/OrthoContextMenu.cpp Diff File

DarkRadiant: undosystem eff78cb7

2021-10-23 14:05:47

greebo

Details Diff
0005408: Start creating a few unit tests to check the existing behaviour Affected Issues
0005408
mod - test/CMakeLists.txt Diff File
add - test/UndoRedo.cpp Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: undosystem bf68b4f3

2021-10-23 14:55:11

greebo

Details Diff
0005408: Add a few tests covering the most important behaviour of the undo system Affected Issues
0005408
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem d9dda734

2021-10-23 16:53:38

greebo

Details Diff
0005408: One more test documenting the current behaviour when undoing/redoing scene node removals Affected Issues
0005408
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 28c612e5

2021-10-24 03:42:43

greebo

Details Diff
0005408: Add test corresponding to issue number 2118 Affected Issues
0005408
mod - test/UndoRedo.cpp Diff File
add - test/resources/tdm/def/moveable.def Diff File
add - test/resources/tdm/def/mover_door.def Diff File
add - test/resources/tdm/def/tdm_frobable.def Diff File

DarkRadiant: undosystem 0a891f9d

2021-10-24 05:14:37

greebo

Details Diff
0005408: Test the map file change tracker which should be tagging the map as modified or unmodified depending on the position in the undo history. Affected Issues
0005408
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 4f676735

2021-10-24 05:35:48

greebo

Details Diff
0005408: Set up a test featuring two unrelated scene graphs. The test fails since the main scene undo command affects the second scene. Affected Issues
0005408
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 1154843d

2021-10-24 07:04:35

greebo

Details Diff
0005408: Prepare to move the postUndo/postRedo signals to the IMap interface. Subscribers should keep getting notified after changing maps, so it's better if they subscribe to IMap instead of the GlobalUndoSystem. Add corresponding unit tests. Affected Issues
0005408
mod - include/imap.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 3c688847

2021-10-24 07:13:00

greebo

Details Diff
0005408: Migrate UI classes to subscribe to the IMap postUndo/postRedo signals instead of the GlobalUndoSystem() Affected Issues
0005408
mod - plugins/dm.editing/AIEditingPanel.cpp Diff File
mod - radiant/textool/TexTool.cpp Diff File
mod - radiant/ui/lightinspector/LightInspector.cpp Diff File
mod - radiant/ui/merge/MergeControlDialog.cpp Diff File
mod - radiant/ui/patch/PatchInspector.cpp Diff File
mod - radiant/ui/surfaceinspector/SurfaceInspector.cpp Diff File
mod - radiantcore/selection/shaderclipboard/ShaderClipboard.cpp Diff File

DarkRadiant: undosystem a53ba84f

2021-10-24 16:05:59

greebo

Details Diff
0005408: After some restructuring and a few paper cuts, the UndoSystem is now a child of the IMapRootNode implementations.
The GlobalUndoSystem() accessor now refers to the GlobalMapModule()'s undo system, the undo system module has been transformed into the GlobalUndoSystemFactory.
I'm not entirely happy with the way the Map module is subscribing to each map resource's undo system on map change, since the root node of a MapResource is not always available.
Affected Issues
0005408
mod - include/imap.h Diff File
mod - include/iundo.h Diff File
mod - libs/scene/BasicRootNode.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiantcore/CMakeLists.txt Diff File
mod - radiantcore/brush/BrushModule.cpp Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/map/RootNode.cpp Diff File
mod - radiantcore/map/RootNode.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File
add - radiantcore/undo/UndoSystemFactory.cpp Diff File
mod - test/UndoRedo.cpp Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj Diff File
mod - tools/msvc/DarkRadiantCore.vcxproj.filters Diff File

DarkRadiant: undosystem b5439e45

2021-10-25 15:38:26

greebo

Details Diff
0005408: Change UndoSystem::Tracker interface which is implemented by the IMapFileChangeTracker. The MapResource is now monitoring the tracked change count and maintains the map modified state accordingly. Affected Issues
0005408
mod - include/iundo.h Diff File
mod - libs/UndoFileChangeTracker.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File

DarkRadiant: undosystem 2144bcbc

2021-10-25 16:21:43

greebo

Details Diff
0005408: Fix change tracker registration/deregistration leak when handling root nodes in the MapResource class. Affected Issues
0005408
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File

DarkRadiant: undosystem dc44cc06

2021-10-25 16:47:33

greebo

Details Diff
0005408: Remove the old pointer-to-member-based state machine in UndoFileChangeTracker. Remove the corresponding methods and the calls to it from UndoSystem. Affected Issues
0005408
mod - include/iundo.h Diff File
mod - include/mapfile.h Diff File
mod - libs/UndoFileChangeTracker.h Diff File
mod - radiantcore/undo/StackFiller.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File

DarkRadiant: undosystem 0e6762ba

2021-10-25 18:18:59

greebo

Details Diff
0005408: The MapResource class no longer calls the internal GlobalMap() singleton to notify about status changes - it could be any map root node firing the change signal, not just the one loaded as primary map. The MapResource now offers a "modified status changed" signal which is subscribed by the main Map class owning it. As another refactoring step, the UndoFileChangeTracker is no longer using a single callback functor, since this can easily overridden if two MapResources are sharing the same root node (which is a valid use case during renaming). Affected Issues
0005408
mod - include/imapresource.h Diff File
mod - include/mapfile.h Diff File
mod - libs/UndoFileChangeTracker.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/MapResource.h Diff File
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 86112a39

2021-10-25 18:41:53

greebo

Details Diff
0005408: Change IMapFileChangeTracker interface to use more descriptive names, add documentation. Affected Issues
0005408
mod - include/iundo.h Diff File
mod - include/mapfile.h Diff File

DarkRadiant: undosystem 9a3824fc

2021-10-25 18:44:53

greebo

Details Diff
0005408: Rename interface header file to imapfilechangetracker.h Affected Issues
0005408
mod - include/imap.h Diff File
mod - include/precompiled_interfaces.h Diff File

DarkRadiant: undosystem d228c9c0

2021-10-25 18:44:53

greebo

Details Diff
0005408: Rename interface header file to imapfilechangetracker.h Affected Issues
0005408
mod - include/imap.h Diff File
mod - include/precompiled_interfaces.h Diff File
mod - libs/ObservedUndoable.h Diff File
mod - libs/UndoFileChangeTracker.h Diff File
mod - libs/scene/BasicRootNode.h Diff File
mod - libs/scene/TraversableNodeSet.cpp Diff File
mod - radiantcore/brush/Face.h Diff File
mod - radiantcore/entity/ModelKey.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/MapResource.cpp Diff File
mod - radiantcore/map/autosaver/AutoSaver.cpp Diff File
mod - radiantcore/map/autosaver/AutoSaver.h Diff File
mod - radiantcore/model/StaticModel.h Diff File
mod - radiantcore/patch/Patch.h Diff File
mod - radiantcore/undo/StackFiller.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - tools/msvc/include.vcxproj Diff File
mod - tools/msvc/include.vcxproj.filters Diff File

DarkRadiant: undosystem 1381730c

2021-10-25 19:31:20

greebo

Details Diff
0005408: No IMapFileChangeTracker reference is needed anymore when acquiring an undo state saver. Affected Issues
0005408
mod - include/iundo.h Diff File
mod - libs/ObservedUndoable.h Diff File
mod - libs/scene/BasicRootNode.h Diff File
mod - libs/scene/Node.cpp Diff File
mod - libs/scene/Node.h Diff File
mod - libs/scene/SelectableNode.cpp Diff File
mod - libs/scene/SelectableNode.h Diff File
mod - libs/scene/TraversableNodeSet.cpp Diff File
mod - libs/scene/TraversableNodeSet.h Diff File
mod - radiantcore/brush/Brush.cpp Diff File
mod - radiantcore/brush/Brush.h Diff File
mod - radiantcore/brush/BrushNode.cpp Diff File
mod - radiantcore/brush/Face.cpp Diff File
mod - radiantcore/brush/Face.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/KeyValue.cpp Diff File
mod - radiantcore/entity/KeyValue.h Diff File
mod - radiantcore/entity/ModelKey.cpp Diff File
mod - radiantcore/entity/ModelKey.h Diff File
mod - radiantcore/entity/SpawnArgs.cpp Diff File
mod - radiantcore/entity/SpawnArgs.h Diff File
mod - radiantcore/entity/doom3group/Doom3GroupNode.cpp Diff File
mod - radiantcore/map/RootNode.cpp Diff File
mod - radiantcore/model/StaticModel.cpp Diff File
mod - radiantcore/model/StaticModel.h Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/patch/Patch.cpp Diff File
mod - radiantcore/patch/Patch.h Diff File
mod - radiantcore/patch/PatchNode.cpp Diff File
mod - radiantcore/undo/StackFiller.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File

DarkRadiant: undosystem 62f57ba5

2021-10-26 03:51:03

greebo

Details Diff
0005408: Use the passed IMapRootNode to acquire the UndoSystem the nodes are connecting to Affected Issues
0005408
mod - include/iundo.h Diff File
mod - libs/ObservedUndoable.h Diff File
mod - libs/scene/Node.cpp Diff File
mod - libs/scene/Node.h Diff File
mod - libs/scene/SelectableNode.cpp Diff File
mod - libs/scene/SelectableNode.h Diff File
mod - libs/scene/TraversableNodeSet.cpp Diff File
mod - libs/scene/TraversableNodeSet.h Diff File
mod - radiantcore/brush/Brush.cpp Diff File
mod - radiantcore/brush/Brush.h Diff File
mod - radiantcore/brush/BrushNode.cpp Diff File
mod - radiantcore/brush/Face.cpp Diff File
mod - radiantcore/brush/Face.h Diff File
mod - radiantcore/entity/EntityNode.cpp Diff File
mod - radiantcore/entity/KeyValue.cpp Diff File
mod - radiantcore/entity/KeyValue.h Diff File
mod - radiantcore/entity/ModelKey.cpp Diff File
mod - radiantcore/entity/ModelKey.h Diff File
mod - radiantcore/entity/SpawnArgs.cpp Diff File
mod - radiantcore/entity/SpawnArgs.h Diff File
mod - radiantcore/entity/doom3group/Doom3GroupNode.cpp Diff File
mod - radiantcore/entity/doom3group/Doom3GroupNode.h Diff File
mod - radiantcore/entity/light/LightNode.cpp Diff File
mod - radiantcore/entity/light/LightNode.h Diff File
mod - radiantcore/map/RootNode.cpp Diff File
mod - radiantcore/map/RootNode.h Diff File
mod - radiantcore/model/StaticModel.cpp Diff File
mod - radiantcore/model/StaticModel.h Diff File
mod - radiantcore/model/StaticModelNode.cpp Diff File
mod - radiantcore/patch/Patch.cpp Diff File
mod - radiantcore/patch/Patch.h Diff File
mod - radiantcore/patch/PatchNode.cpp Diff File
mod - radiantcore/undo/StackFiller.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File

DarkRadiant: undosystem bb0e005a

2021-10-26 04:00:58

greebo

Details Diff
0005408: Remove unused method Affected Issues
0005408
mod - include/iundo.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File

DarkRadiant: undosystem 918a1ce2

2021-10-26 04:13:45

greebo

Details Diff
0005408: Refactoring Affected Issues
0005408
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File

DarkRadiant: undosystem 98704ce0

2021-10-26 05:03:06

greebo

Details Diff
0005408: IUndoStateSaver doesn't need the IUndoable reference as argument, it can be associated at construction time. Affected Issues
0005408
mod - include/iundo.h Diff File
mod - libs/ObservedUndoable.h Diff File
mod - libs/scene/SelectableNode.cpp Diff File
mod - libs/scene/TraversableNodeSet.cpp Diff File
mod - radiantcore/brush/Brush.cpp Diff File
mod - radiantcore/brush/Face.cpp Diff File
mod - radiantcore/model/StaticModel.cpp Diff File
mod - radiantcore/patch/Patch.cpp Diff File
mod - radiantcore/undo/StackFiller.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File

DarkRadiant: undosystem f881e461

2021-10-26 06:17:13

greebo

Details Diff
0005408: Some refactoring Affected Issues
0005408
mod - radiantcore/undo/Operation.h Diff File
mod - radiantcore/undo/Stack.h Diff File
mod - radiantcore/undo/StackFiller.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 7c99e2cd

2021-10-26 09:40:53

greebo

Details Diff
0005408: IUndoables are notified about a restore operation being finished (without having to subscribe). This replaces the code in TraversableNodeSet subscribing to the GlobalUndoSystem instance to perform the node insertions after undo/redo. Affected Issues
0005408
mod - include/iundo.h Diff File
mod - libs/scene/TraversableNodeSet.cpp Diff File
mod - libs/scene/TraversableNodeSet.h Diff File
mod - radiantcore/undo/Operation.h Diff File

DarkRadiant: undosystem cbfae9f6

2021-10-26 10:05:26

greebo

Details Diff
0005408: Replace the second occurrence of GlobalUndoSystem() event subscriptions in the entity KeyValue class. Affected Issues
0005408
mod - libs/ObservedUndoable.h Diff File
mod - radiantcore/entity/KeyValue.cpp Diff File
mod - radiantcore/entity/KeyValue.h Diff File
mod - radiantcore/entity/SpawnArgs.cpp Diff File

DarkRadiant: undosystem c4f7a6f0

2021-10-26 10:21:03

greebo

Details Diff
0005408: Simplify the code in TraversableNodeSet a bit, there's a C++ standard equivalent which can be used to insert the different nodes into a target container. Affected Issues
0005408
mod - libs/scene/TraversableNodeSet.cpp Diff File

DarkRadiant: undosystem 22631517

2021-10-27 17:35:51

greebo

Details Diff
0005408: Set up infrastructure to show the last named map operation in the status bar Affected Issues
0005408
mod - include/imessagebus.h Diff File
mod - include/iundo.h Diff File
mod - include/ui/istatusbarmanager.h Diff File
add - libs/messages/MapOperationMessage.h Diff File
mod - radiant/CMakeLists.txt Diff File
mod - radiant/ui/UserInterfaceModule.cpp Diff File
mod - radiant/ui/UserInterfaceModule.h Diff File
add - radiant/ui/statusbar/CommandStatus.cpp Diff File
add - radiant/ui/statusbar/CommandStatus.h Diff File
mod - radiant/ui/statusbar/StatusBarManager.cpp Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - tools/msvc/DarkRadiant.vcxproj Diff File
mod - tools/msvc/DarkRadiant.vcxproj.filters Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: undosystem f18aa2d3

2021-10-27 17:45:33

greebo

Details Diff
0005408: Messages have a time to live before they disappear Affected Issues
0005408
mod - radiant/ui/statusbar/CommandStatus.cpp Diff File
mod - radiant/ui/statusbar/CommandStatus.h Diff File
mod - radiant/ui/statusbar/StatusBarManager.cpp Diff File

DarkRadiant: undosystem c813c212

2021-10-27 18:20:22

greebo

Details Diff
0005408: Extend the IUndoSystem::Tracker interface to include the operation name Affected Issues
0005408
mod - include/iundo.h Diff File
mod - libs/UndoFileChangeTracker.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 74e6d3e4

2021-10-28 19:22:01

greebo

Details Diff
0005408: Remove IUndoSystem::Tracker interface in favour of a sigc++ signal, which has safer ways of unsubscribing. Affected Issues
0005408
mod - include/iundo.h Diff File
mod - libs/UndoFileChangeTracker.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/map/RootNode.cpp Diff File
mod - radiantcore/map/RootNode.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File
mod - test/UndoRedo.cpp Diff File

DarkRadiant: undosystem 4e9291a2

2021-10-29 05:06:25

greebo

Details Diff
0005408: Remove now redundant signals from IUndoSystem that are covered by signal_undoEvent() Affected Issues
0005408
mod - include/iundo.h Diff File
mod - radiantcore/map/Map.cpp Diff File
mod - radiantcore/map/Map.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File

DarkRadiant: undosystem d6612b8d

2021-10-29 05:37:58

greebo

Details Diff
0005408: Each scenegraph can monitor its own root node undo system, it doesn't need to be actively called from every undo system instance. Affected Issues
0005408
mod - radiantcore/scenegraph/SceneGraph.cpp Diff File
mod - radiantcore/scenegraph/SceneGraph.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File

DarkRadiant: undosystem 444b66e7

2021-10-29 05:50:27

greebo

Details Diff
0005408: Re-implement IUndoSystem::cancel(). The pending operation is no longer pushed to the stack only to be removed immediately afterwards. Affected Issues
0005408
mod - radiantcore/undo/Stack.h Diff File
mod - radiantcore/undo/UndoSystem.cpp Diff File
mod - radiantcore/undo/UndoSystem.h Diff File

DarkRadiant: master 7f50a99d

2021-10-29 07:02:24

greebo

Details Diff
0005408: Remove superfluous call to Map::connectToUndoSystem Affected Issues
0005408
mod - radiantcore/map/Map.cpp Diff File

Issue History

Date Modified Username Field Change
14.11.2020 08:00 greebo New Issue
14.11.2020 08:00 greebo Relationship added related to 0005402
14.11.2020 08:00 greebo Status new => confirmed
14.11.2020 08:01 greebo Summary Move UndoSystem / Change Tracker to Map Root node => All scene graphs connect to the same undo system, causing interference
26.06.2021 18:10 greebo Note Added: 0014127
26.06.2021 18:16 greebo Changeset attached => DarkRadiant master d13fd481
29.06.2021 12:45 MirceaKitsune Note Added: 0014134
24.10.2021 04:44 greebo Assigned To => greebo
24.10.2021 04:44 greebo Status confirmed => assigned
24.10.2021 04:44 greebo Changeset attached => DarkRadiant undosystem eff78cb7
24.10.2021 04:44 greebo Changeset attached => DarkRadiant undosystem bf68b4f3
24.10.2021 04:44 greebo Changeset attached => DarkRadiant undosystem d9dda734
24.10.2021 04:44 greebo Changeset attached => DarkRadiant undosystem 28c612e5
24.10.2021 04:45 greebo Description Updated
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 0a891f9d
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 4f676735
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 1154843d
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 3c688847
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem a53ba84f
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem b5439e45
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 2144bcbc
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem dc44cc06
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 0e6762ba
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 86112a39
25.10.2021 18:46 greebo Changeset attached => DarkRadiant undosystem 9a3824fc
25.10.2021 18:48 greebo Changeset attached => DarkRadiant undosystem d228c9c0
26.10.2021 04:02 greebo Changeset attached => DarkRadiant undosystem 1381730c
26.10.2021 04:02 greebo Changeset attached => DarkRadiant undosystem 62f57ba5
26.10.2021 04:02 greebo Changeset attached => DarkRadiant undosystem bb0e005a
26.10.2021 10:25 greebo Changeset attached => DarkRadiant undosystem 918a1ce2
26.10.2021 10:25 greebo Changeset attached => DarkRadiant undosystem 98704ce0
26.10.2021 10:25 greebo Changeset attached => DarkRadiant undosystem f881e461
26.10.2021 10:25 greebo Changeset attached => DarkRadiant undosystem 7c99e2cd
26.10.2021 10:25 greebo Changeset attached => DarkRadiant undosystem cbfae9f6
26.10.2021 10:25 greebo Changeset attached => DarkRadiant undosystem c4f7a6f0
28.10.2021 19:22 greebo Changeset attached => DarkRadiant undosystem 22631517
28.10.2021 19:22 greebo Changeset attached => DarkRadiant undosystem f18aa2d3
28.10.2021 19:22 greebo Changeset attached => DarkRadiant undosystem c813c212
28.10.2021 19:22 greebo Changeset attached => DarkRadiant undosystem 74e6d3e4
29.10.2021 05:53 greebo Changeset attached => DarkRadiant undosystem 4e9291a2
29.10.2021 05:53 greebo Changeset attached => DarkRadiant undosystem d6612b8d
29.10.2021 05:53 greebo Changeset attached => DarkRadiant undosystem 444b66e7
29.10.2021 06:02 greebo Target Version => 2.14.0
29.10.2021 06:02 greebo Status assigned => resolved
29.10.2021 06:02 greebo Resolution open => fixed
29.10.2021 06:02 greebo Fixed in Version => 2.14.0
29.10.2021 10:51 greebo Changeset attached => DarkRadiant master 7f50a99d
29.10.2021 17:47 greebo Relationship added related to 0005505