View Issue Details

IDProjectCategoryView StatusLast Update
0005422DarkRadiantSaving and loadingpublic20.11.2020 15:23
ReporterSpooks Assigned Togreebo  
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version2.9.0 
Target Version2.9.1Fixed in Version2.9.1 
Summary0005422: DR freezes when saving from the "Exit DarkRadiant" dialogue
DescriptionThe save on exit functionality is broken for me. When clicking "Save" in the "Do you want to save "mapname" before quitting?" dialogue I get an indefinite hang (the explorer dialogue doesn't show up). (Un)fortunately I can't seem to reproduce it consistently, but I'd say I get it 3/5 times.
Steps To ReproduceIt can happen with a fresh map. Start DR, drag to make a brush, exit, click Save on the dialogue.
Additional InformationIf it's hard to reproduce on others' ends I can provide a crashdump.
TagsNo tags attached.

Relationships

has duplicate 0005423 closedgreebo 2.9pre3 - I am getting occasional crash-freeze on save and shutdown. 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master bd5d60be

2020-11-18 17:55:07

greebo

Details Diff
0005422: Fix deadlock when saving an unsaved map on exiting the application.
Caused by the EditStopwatch thread trying to use the MessageBus with the main thread blocking it.
Affected Issues
0005422
mod - radiantcore/messagebus/MessageBus.h Diff File

DarkRadiant: master ac0ed1fb

2020-11-18 18:37:23

greebo

Details Diff
0005422: Add unit tests covering the MessageBus behaviour Affected Issues
0005422
mod - test/Makefile.am Diff File
add - test/MessageBus.cpp Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

Issue History

Date Modified Username Field Change
18.11.2020 15:35 Spooks New Issue
18.11.2020 16:14 greebo Status new => confirmed
19.11.2020 03:08 greebo Changeset attached => DarkRadiant master bd5d60be
19.11.2020 03:08 greebo Changeset attached => DarkRadiant master ac0ed1fb
19.11.2020 03:08 greebo Assigned To => greebo
19.11.2020 03:08 greebo Status confirmed => assigned
19.11.2020 03:08 greebo Target Version => 2.9.1
19.11.2020 03:08 greebo Status assigned => resolved
19.11.2020 03:08 greebo Resolution open => fixed
19.11.2020 03:08 greebo Fixed in Version => 2.9.1
20.11.2020 15:23 greebo Relationship added has duplicate 0005423