View Issue Details

IDProjectCategoryView StatusLast Update
0005444DarkRadiantGUIpublic05.09.2021 18:21
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionfixed 
Product Version2.10.0 
Target Version2.10.0Fixed in Version2.10.0 
Summary0005444: Brushes with no visible surface towards orthoview "camera" are unselectable in orthoview
DescriptionIf I use filters to hide 5 out of 6 surfaces on a brush, and the 6th surface faces away from the direction that orthoview is looking at it, the brush is unselectable in orthoview.

For example, if I'm in top-down orthoview (looking down onto the map), and the sole visible surface of a brush is facing downwards.
Steps To Reproduce1) Create a brush, texture it with caulk. Duplicate it and move the copy to the side horizontally.
2) Apply the rough_wood_darkbrown material to the upfacing surface of one brush and to the downfacing surface of the other brush.
3) Make sure you're in top-down orthoview, then enable the caulk filter.
4) Drag-select over where both brushes should be. Only the brush with the topfacing rough_wood_darkbrown surface becomes selected.
TagsNo tags attached.

Relationships

related to 0004735 closedgreebo Can't select one-sided models in certain 2D views 
related to 0005465 closedgreebo Brushes with no visible surface towards orthoview "camera" are invisible in orthoview 

Activities

greebo

greebo

25.12.2020 13:41

administrator   ~0013193

This is resolved as the hidden brush is selectable again - nothing has changed with regards of their visibility.

Related Changesets

DarkRadiant: master 610a3cbd

2020-12-25 10:09:07

greebo

Details Diff
0005444: Fix brushes being unselectable when their only visible surfaces are facing away in orthoview. Affected Issues
0005444
mod - radiantcore/brush/BrushNode.cpp Diff File

DarkRadiant: master 5ee83794

2020-12-25 11:30:36

greebo

Details Diff
0005444: Add unit test covering the fixed selection behaviour of these brushes facing the opposite direction in orthoview. Affected Issues
0005444
mod - test/Selection.cpp Diff File
add - test/resources/tdm/maps/selection_test.map Diff File

DarkRadiant: master 0e25f166

2020-12-25 11:36:16

greebo

Details Diff
0005444: Add another unit test covering patches facing both directions in orthoview Affected Issues
0005444
mod - test/Selection.cpp Diff File

DarkRadiant: master 1e546235

2021-02-03 17:15:51

greebo

Details Diff
0005266: Pass the two-sided flag only if the material is actually two-sided (exception: brush faces should always be treated like they're twosided due to 0005444).
Adjusted the cull type determination code in SelectionVolume::BeginMesh.
Affected Issues
0005266, 0005444
mod - libs/selection/SelectionVolume.h Diff File
mod - radiantcore/brush/BrushNode.cpp Diff File
mod - radiantcore/model/picomodel/StaticModel.cpp Diff File
mod - radiantcore/model/picomodel/StaticModelSurface.cpp Diff File
mod - radiantcore/model/picomodel/StaticModelSurface.h Diff File
mod - radiantcore/patch/PatchNode.cpp Diff File

Issue History

Date Modified Username Field Change
16.12.2020 13:16 Dragofer New Issue
16.12.2020 20:52 Judith Relationship added child of 0004735
25.12.2020 09:50 greebo Status new => confirmed
25.12.2020 11:30 greebo Assigned To => greebo
25.12.2020 11:30 greebo Status confirmed => assigned
25.12.2020 11:37 greebo Changeset attached => DarkRadiant master 610a3cbd
25.12.2020 11:37 greebo Changeset attached => DarkRadiant master 5ee83794
25.12.2020 11:37 greebo Changeset attached => DarkRadiant master 0e25f166
25.12.2020 13:37 greebo Relationship replaced related to 0004735
25.12.2020 13:40 greebo Target Version => 2.10.0
25.12.2020 13:41 greebo Status assigned => resolved
25.12.2020 13:41 greebo Resolution open => fixed
25.12.2020 13:41 greebo Fixed in Version => 2.10.0
25.12.2020 13:41 greebo Note Added: 0013193
26.12.2020 14:02 Dragofer Summary Brushes with no visible surface towards orthoview "camera" are invisible & unselectable in orthoview => Brushes with no visible surface towards orthoview "camera" are unselectable in orthoview
26.12.2020 14:03 Dragofer Issue cloned: 0005465
26.12.2020 14:03 Dragofer Relationship added related to 0005465
26.12.2020 14:03 Dragofer Description Updated
26.12.2020 14:03 Dragofer Steps to Reproduce Updated
03.02.2021 17:26 greebo Changeset attached => DarkRadiant master 1e546235
05.09.2021 18:21 greebo Status resolved => closed