View Issue Details

IDProjectCategoryView StatusLast Update
0005541DarkRadiantGUIpublic23.02.2021 20:18
Reporterorbweaver Assigned Toorbweaver  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.11.0 
Target Version2.12.0Fixed in Version2.12.0 
Summary0005541: Customisable GUI layout
DescriptionSome users would prefer more customisability than is available with current layouts. The wxWidgets AUI library might be useful for this, since it provides dockable panels which can be floated or re-ordered into various configurations.
TagsNo tags attached.

Activities

orbweaver

orbweaver

23.02.2021 20:18

developer   ~0013724

As of 7a69f45a861e50fda80087b7b1be5e25e74e2fb0 the new AUI layout is the default for new installations, but will not replace any existing layouts for current users. I think this strikes a reasonable balance between encouraging testing and use of the new layout vs not disrupting anyone's existing workflow.

Issue History

Date Modified Username Field Change
21.02.2021 20:38 orbweaver New Issue
21.02.2021 20:38 orbweaver Status new => assigned
21.02.2021 20:38 orbweaver Assigned To => orbweaver
23.02.2021 20:18 orbweaver Status assigned => resolved
23.02.2021 20:18 orbweaver Resolution open => fixed
23.02.2021 20:18 orbweaver Fixed in Version => 2.12.0
23.02.2021 20:18 orbweaver Note Added: 0013724