View Issue Details

IDProjectCategoryView StatusLast Update
0005586DarkRadiantGUIpublic11.04.2021 17:49
Reportergreebo Assigned Togreebo  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindows 
Product Version2.12.0 
Target Version2.12.0Fixed in Version2.12.0 
Summary0005586: Crash at shutdown when Dockable layout is active
DescriptionWhen shutting down the TopLevelFrame, the code crashes somewhere in the depths of wxWidgets, see attached stacktrace.
Additional InformationStacktrace:
> wxbase313ud_vc14x_x64.dll!wxEvtHandler::SafelyProcessEvent(wxEvent & event) Line 1636 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindowBase::HandleWindowEvent(wxEvent & event) Line 1556 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::HandleSize(int __formal, int __formal, unsigned int wParam) Line 5676 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWHandleMessage(__int64 * result, unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 2992 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 3873 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWndProc(HWND__ * hWnd, unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 2940 C++
     user32.dll!UserCallWinProcCheckWow() Unknown
     user32.dll!DispatchClientMessage() Unknown
     user32.dll!__fnDWORD() Unknown
     ntdll.dll!00007ffb94ff0a44() Unknown
     win32u.dll!NtUserMessageCall() Unknown
     user32.dll!SendMessageWorker(struct tagWND *,unsigned int,unsigned __int64,__int64,int) Unknown
     user32.dll!RealDefWindowProcWorker() Unknown
     user32.dll!RealDefWindowProcW() Unknown
     uxtheme.dll!00007ffb8cc5b8d9() Unknown
     uxtheme.dll!00007ffb8cc5b2c1() Unknown
     user32.dll!DefWindowProcW() Unknown
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWDefWindowProc(unsigned int nMsg, unsigned __int64 wParam, __int64 lParam) Line 2484 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 3879 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWndProc(HWND__ * hWnd, unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 2940 C++
     user32.dll!UserCallWinProcCheckWow() Unknown
     user32.dll!DispatchClientMessage() Unknown
     user32.dll!__fnINLPWINDOWPOS() Unknown
     ntdll.dll!00007ffb94ff0a44() Unknown
     win32u.dll!NtUserEndDeferWindowPosEx() Unknown
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::EndRepositioningChildren() Line 5622 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindowBase::ChildrenRepositioningGuard::~ChildrenRepositioningGuard() Line 595 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::HandleSize(int __formal, int __formal, unsigned int wParam) Line 5680 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWHandleMessage(__int64 * result, unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 2992 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 3873 C++
     wxmsw313ud_core_vc14x_x64.dll!wxTopLevelWindowMSW::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 346 C++
     wxmsw313ud_core_vc14x_x64.dll!wxFrame::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 912 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWndProc(HWND__ * hWnd, unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 2940 C++
     user32.dll!UserCallWinProcCheckWow() Unknown
     user32.dll!DispatchClientMessage() Unknown
     user32.dll!__fnDWORD() Unknown
     ntdll.dll!00007ffb94ff0a44() Unknown
     win32u.dll!NtUserMessageCall() Unknown
     user32.dll!SendMessageWorker(struct tagWND *,unsigned int,unsigned __int64,__int64,int) Unknown
     user32.dll!RealDefWindowProcWorker() Unknown
     user32.dll!RealDefWindowProcW() Unknown
     uxtheme.dll!00007ffb8cc5b8d9() Unknown
     uxtheme.dll!00007ffb8cc5b2c1() Unknown
     user32.dll!DefWindowProcW() Unknown
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWDefWindowProc(unsigned int nMsg, unsigned __int64 wParam, __int64 lParam) Line 2484 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWindow::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 3879 C++
     wxmsw313ud_core_vc14x_x64.dll!wxTopLevelWindowMSW::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 346 C++
     wxmsw313ud_core_vc14x_x64.dll!wxFrame::MSWWindowProc(unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 912 C++
     wxmsw313ud_core_vc14x_x64.dll!wxWndProc(HWND__ * hWnd, unsigned int message, unsigned __int64 wParam, __int64 lParam) Line 2940 C++
     user32.dll!UserCallWinProcCheckWow() Unknown
     user32.dll!DispatchClientMessage() Unknown
     user32.dll!__fnINLPWINDOWPOS() Unknown
     ntdll.dll!00007ffb94ff0a44() Unknown
     win32u.dll!NtUserCallHwndLock() Unknown
     wxmsw313ud_core_vc14x_x64.dll!wxMenuBar::Refresh() Line 891 C++
     wxmsw313ud_core_vc14x_x64.dll!wxMenuBar::Remove(unsigned __int64 pos) Line 1191 C++
     DarkRadiant.exe!ui::menu::MenuFolder::deconstruct() Line 114 C++
     DarkRadiant.exe!ui::menu::MenuElement::deconstructChildren() Line 310 C++
     DarkRadiant.exe!ui::menu::MenuBar::deconstruct() Line 86 C++
     DarkRadiant.exe!ui::menu::MenuElement::deconstructChildren() Line 310 C++
     DarkRadiant.exe!ui::menu::MenuRootElement::~MenuRootElement() Line 21 C++
     DarkRadiant.exe!ui::menu::MenuRootElement::`scalar deleting destructor'(unsigned int) C++
     DarkRadiant.exe!std::_Ref_count<ui::menu::MenuRootElement>::_Destroy() Line 671 C++
     DarkRadiant.exe!std::_Ref_count_base::_Decref() Line 644 C++
     DarkRadiant.exe!std::_Ptr_base<ui::menu::MenuElement>::_Decref() Line 878 C++
     DarkRadiant.exe!std::shared_ptr<ui::menu::MenuElement>::~shared_ptr<ui::menu::MenuElement>() Line 1170 C++
     DarkRadiant.exe!std::shared_ptr<ui::menu::MenuElement>::reset() Line 1214 C++
     DarkRadiant.exe!ui::menu::MenuManager::clear() Line 31 C++
     DarkRadiant.exe!sigc::bound_mem_functor0<void,ui::menu::MenuManager>::operator()() Line 1787 C++
     DarkRadiant.exe!sigc::adaptor_functor<sigc::bound_mem_functor0<void,ui::menu::MenuManager>>::operator()() Line 251 C++
     DarkRadiant.exe!sigc::internal::slot_call0<sigc::bound_mem_functor0<void,ui::menu::MenuManager>,void>::call_it(sigc::internal::slot_rep * rep) Line 104 C++
     DarkRadiant.exe!sigc::internal::signal_emit0<void,sigc::nil>::emit(sigc::internal::signal_impl * impl) Line 772 C++
     DarkRadiant.exe!sigc::signal0<void,sigc::nil>::emit() Line 2667 C++
     DarkRadiant.exe!ui::MainFrame::onTopLevelFrameClose(wxCloseEvent & ev) Line 352 C++
TagsNo tags attached.

Relationships

related to 0005541 resolvedorbweaver Customisable GUI layout 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 960c2599

2021-04-11 17:47:27

greebo

Details Diff
0005586: Fix crash at shutdown in wxMSW due to the wxAuiManager not unregistering itself from the managed window Affected Issues
0005586
mod - radiant/ui/mainframe/AuiLayout.cpp Diff File

DarkRadiant: master 1b8deff8

2021-04-11 17:48:40

greebo

Details Diff
0005586: Better call Destroy instead of deleting the window manually Affected Issues
0005586
mod - radiant/ui/mainframe/AuiLayout.cpp Diff File

Issue History

Date Modified Username Field Change
11.04.2021 17:19 greebo New Issue
11.04.2021 17:19 greebo Status new => confirmed
11.04.2021 17:46 greebo Assigned To => greebo
11.04.2021 17:46 greebo Status confirmed => assigned
11.04.2021 17:47 greebo Changeset attached => DarkRadiant master 960c2599
11.04.2021 17:48 greebo Changeset attached => DarkRadiant master 1b8deff8
11.04.2021 17:49 greebo Status assigned => resolved
11.04.2021 17:49 greebo Resolution open => fixed
11.04.2021 17:49 greebo Fixed in Version => 2.12.0
11.04.2021 17:49 greebo Relationship added related to 0005541