View Issue Details

IDProjectCategoryView StatusLast Update
0005613DarkRadiantGUIpublic20.11.2021 17:29
ReporterBrendonChung Assigned Togreebo  
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.12.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0005613: Show shared keyvalues when multiple entities are selected
DescriptionCurrently, when multiple entities are selected and the Entity Inspector (N) is open, the keyvalue fields are all empty.

I thought it could be useful to display a union of keyvalues, to make it easier to compare and view the entities, and make it easier to make batch changes:
- with common values showing the keyvalue.
- and with differing values showing the pseudo-value of "[different]", or something like that.

I attached a rough mockup image of this idea.
TagsNo tags attached.

Relationships

related to 0005813 resolvedgreebo Spawnarg types and tooltips not reliably inherited in entityDefs 

Activities

BrendonChung

BrendonChung

13.05.2021 19:55

reporter  

entityinspector.png (45,698 bytes)   
entityinspector.png (45,698 bytes)   
orbweaver

orbweaver

20.05.2021 19:51

developer   ~0014036

Not a bad idea. We could also change the "Entity 7" title text to say something like "[4 entities]".
greebo

greebo

22.10.2021 13:45

administrator   ~0014443

grafik.png (10,214 bytes)   
grafik.png (10,214 bytes)   

Related Changesets

DarkRadiant: entityinspector 0874508e

2021-10-15 03:21:39

greebo

Details Diff
0005613: Introduce EntitySelection tracker keeping an eye on the selected entities in the scene.
Add shutdown cleanup code to EntityInspector.
Affected Issues
0005613
add - libs/selection/EntitySelection.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: entityinspector 24b0da82

2021-10-15 10:56:41

greebo

Details Diff
0005613: Implement the basic scene node tracking code to handle more than one entity. EntityInspector is still working in the single selection case only, but can display the number of selected entities in the other cases. Affected Issues
0005613
mod - libs/selection/EntitySelection.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 5599d144

2021-10-15 14:16:31

greebo

Details Diff
0005613: Next iteration, this now shows all the keys of all entities. Affected Issues
0005613
mod - libs/selection/EntitySelection.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector a2cedef4

2021-10-15 17:30:06

greebo

Details Diff
0005613: Start setting up the unit test scenario Affected Issues
0005613
add - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File
add - test/EntityInspector.cpp Diff File
add - test/resources/tdm/maps/entityinspector.map Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File
mod - tools/msvc/libs.vcxproj Diff File
mod - tools/msvc/libs.vcxproj.filters Diff File

DarkRadiant: entityinspector bcfac235

2021-10-15 18:38:57

greebo

Details Diff
0005613: Sketched out a few unit test cases. Implementation is still lacking, as is the unit test code making use of it. Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 585880ae

2021-10-15 19:06:57

greebo

Details Diff
0005613: Signal signatures Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector d122fef5

2021-10-16 04:15:14

greebo

Details Diff
0005613: Start implementing the easy cases. Fix destruction order problems. Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 20b508ef

2021-10-16 04:47:17

greebo

Details Diff
0005613: Working on the key value logic Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

DarkRadiant: entityinspector f51e5371

2021-10-16 05:25:39

greebo

Details Diff
0005613: Removing key values can change a value set's status again. More test cases. Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector c95041f2

2021-10-16 06:14:03

greebo

Details Diff
0005613: Cover the case that newly selected entities are lacking some keys that had values shared by all entities before. Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 7341bdcf

2021-10-16 07:20:39

greebo

Details Diff
0005613: Re-arrange the code that checks values for uniqueness on removing a single key and on removing the whole entity, sharing the same logic Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File

DarkRadiant: entityinspector cc265469

2021-10-16 07:54:29

greebo

Details Diff
0005613: More tracking and signal emission logic. Some docs. Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 40be3e61

2021-10-16 10:56:43

greebo

Details Diff
0005613: Fix signal emission on changed key value Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File

DarkRadiant: entityinspector 54be9e99

2021-10-16 11:09:19

greebo

Details Diff
0005613: Refactoring to not dereference the raw Entity* pointer which might be stale Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File

DarkRadiant: entityinspector b4b6c10d

2021-10-16 11:28:07

greebo

Details Diff
0005613: Disengage the existing key value handling code in EntityInspector. Key value addition/removal/update is now exclusively handled by listening to the signals emitted by the CollectiveSpawnargs helper. A couple of things stopped working at this point. Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector 09905ebc

2021-10-16 12:16:39

greebo

Details Diff
0005613: Change ownership of the CollectiveSpawnargs helper. It's now owned and listened to by the EntityInspector, the EntitySelection class merely monitors the selection and dispatches the key observer events. Affected Issues
0005613
mod - libs/selection/EntitySelection.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 2f1d9859

2021-10-16 13:50:34

greebo

Details Diff
0005613: Remove _selectedEntity member from EntityInspector, which supposedly introduces more breakage Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector e275e9dd

2021-10-16 18:23:01

greebo

Details Diff
0005613: Reorganise the whole PropertyEditor framework. Change virtual constructors to factory function object, to be able to use references in the property editor instances. Separate the IPropertyEditorDialog implementations from the editors. Affected Issues
0005613
mod - include/ientity.h Diff File
mod - include/ui/ientityinspector.h Diff File
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File
mod - plugins/dm.editing/AIEditingPanel.cpp Diff File
mod - plugins/dm.editing/AIHeadPropertyEditor.cpp Diff File
mod - plugins/dm.editing/AIHeadPropertyEditor.h Diff File
mod - plugins/dm.editing/AIVocalSetPropertyEditor.cpp Diff File
mod - plugins/dm.editing/AIVocalSetPropertyEditor.h Diff File
mod - plugins/dm.editing/plugin.cpp Diff File
mod - radiant/ui/einspector/AnglePropertyEditor.cpp Diff File
mod - radiant/ui/einspector/AnglePropertyEditor.h Diff File
mod - radiant/ui/einspector/BooleanPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/BooleanPropertyEditor.h Diff File
mod - radiant/ui/einspector/ClassnamePropertyEditor.cpp Diff File
mod - radiant/ui/einspector/ClassnamePropertyEditor.h Diff File
mod - radiant/ui/einspector/ColourPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/ColourPropertyEditor.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File
mod - radiant/ui/einspector/EntityPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/EntityPropertyEditor.h Diff File
mod - radiant/ui/einspector/FloatPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/FloatPropertyEditor.h Diff File
mod - radiant/ui/einspector/ModelPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/ModelPropertyEditor.h Diff File
mod - radiant/ui/einspector/PropertyEditor.cpp Diff File
mod - radiant/ui/einspector/PropertyEditor.h Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.cpp Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.h Diff File
mod - radiant/ui/einspector/SkinPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/SkinPropertyEditor.h Diff File
mod - radiant/ui/einspector/SoundPropertyEditor.cpp Diff File
mod - radiant/ui/einspector/SoundPropertyEditor.h Diff File
mod - radiant/ui/einspector/TexturePropertyEditor.cpp Diff File
mod - radiant/ui/einspector/TexturePropertyEditor.h Diff File
mod - radiant/ui/einspector/Vector3PropertyEditor.cpp Diff File
mod - radiant/ui/einspector/Vector3PropertyEditor.h Diff File

DarkRadiant: entityinspector a712aa77

2021-10-17 03:43:25

greebo

Details Diff
0005613: PropertyEditorFactory is no longer a static class and is now owned by the EntityInspector module. Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.cpp Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.h Diff File

DarkRadiant: entityinspector 0429c9cc

2021-10-17 03:49:43

greebo

Details Diff
0005613: Module setup is not finished by the time the PropertyEditorFactory is registering the built-in types, so the sound module may or may not be available at that time. Disable the sound editor if the module is not present in the editor's constructor instead. Affected Issues
0005613
mod - radiant/ui/einspector/PropertyEditorFactory.cpp Diff File
mod - radiant/ui/einspector/PropertyEditorFactory.h Diff File
mod - radiant/ui/einspector/SoundPropertyEditor.cpp Diff File
mod - test/resources/tdm/maps/entityinspector.map Diff File

DarkRadiant: entityinspector f060e712

2021-10-17 04:05:20

greebo

Details Diff
0005613: Entity KeyValue objects now hold a reference to the owning SpawnArgs instance. This is a preparation to notify the owner on Undo/Redo when just a single key value is being reverted to a previous state - right now the SpawnArgs owner doesn't get notified. Affected Issues
0005613
mod - radiantcore/entity/KeyValue.cpp Diff File
mod - radiantcore/entity/KeyValue.h Diff File
mod - radiantcore/entity/SpawnArgs.cpp Diff File

DarkRadiant: entityinspector 6f1e2918

2021-10-17 04:21:57

greebo

Details Diff
0005613: Start creating unit tests covering the Entity::Observer behaviour Affected Issues
0005613
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector 2effcb45

2021-10-17 04:33:30

greebo

Details Diff
0005613: More test cases covering key value addition, removal and change Affected Issues
0005613
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector 66bd95d4

2021-10-17 05:11:28

greebo

Details Diff
0005613: Tests covering the EntityKeyValue observer behaviour on regular change and removal. Affected Issues
0005613
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector 0d15e808

2021-10-17 06:16:07

greebo

Details Diff
0005613: Long integration test covering the Entity::Observer behaviour on undo/redo. It already reveals odd behaviour when EntityKeyValue instances are directly changed in combination with key values being added or removed to a SpawnArgs collection during the same operation. Affected Issues
0005613
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector 27109f78

2021-10-17 07:25:38

greebo

Details Diff
0005613: Check KeyObserver persistence after undoing an operation. Make KeyValue sealed and noncopyable. Affected Issues
0005613
mod - radiantcore/entity/KeyValue.h Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector af12115a

2021-10-17 07:31:07

greebo

Details Diff
0005613: Add test covering KeyObservers being notified on Undo/Redo of a single key value change Affected Issues
0005613
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector e610aa45

2021-10-17 14:08:46

greebo

Details Diff
0005613: Add first failing test checking the fact that changing a single key in an undoable operation will not trigger the Entity::Observer::onKeyChanged method as it should. This is the reason the Entity Inspector doesn't display the updated values after undo/redo. Affected Issues
0005613
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector b268207e

2021-10-17 14:48:34

greebo

Details Diff
0005613: Add an additional callback line between SpawnArgs and the owned KeyValue instance - once the instance gets a new value assigned (in whatever way) the SpawnArgs instance can trigger its notifyChange() method, which didn't happen before. Affected Issues
0005613
mod - radiantcore/entity/KeyValue.cpp Diff File
mod - radiantcore/entity/KeyValue.h Diff File
mod - radiantcore/entity/SpawnArgs.cpp Diff File
mod - test/Entity.cpp Diff File

DarkRadiant: entityinspector f349ecc5

2021-10-17 15:14:48

greebo

Details Diff
0005613: Extend EntityInspector tests to prove that undo/redo is notifying the CollectiveSpawnargs values Affected Issues
0005613
mod - test/Entity.cpp Diff File
mod - test/EntityInspector.cpp Diff File
add - test/algorithm/Entity.h Diff File
mod - tools/msvc/Tests/Tests.vcxproj Diff File
mod - tools/msvc/Tests/Tests.vcxproj.filters Diff File

DarkRadiant: entityinspector b9d53176

2021-10-17 15:34:07

greebo

Details Diff
0005613: Display the ambiguous values in italics (if supported) Affected Issues
0005613
mod - libs/wxutil/dataview/TreeViewItemStyle.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector efcf6c7d

2021-10-17 15:36:30

greebo

Details Diff
0005613: EntityInspector no longer needs to implement Entity::Observer Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector 464ec1fc

2021-10-17 17:30:44

greebo

Details Diff
0005613: Inherited properties can be displayed if there's a single classname shared by all selected entities. Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector fb0ed634

2021-10-17 17:31:20

greebo

Details Diff
0005613: Even if a scene::Node got deleted, we still need to notify the spawnarg collection about this. Add corresponding unit test. Affected Issues
0005613
mod - libs/selection/EntitySelection.h Diff File
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 0a96b48c

2021-10-17 18:23:22

greebo

Details Diff
0005613: Help text is now handled in the idle loop, no need to do this detailed eclass queries for each and every key during scene selection changes Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector b7cba693

2021-10-18 17:39:53

greebo

Details Diff
0005613: One more test case covering a display problem when de-selecting entities Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 56190d44

2021-10-18 18:14:46

greebo

Details Diff
0005613: Fix keys not re-appearing after de-selecting the one entity that was preventing the keys to show up Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File

DarkRadiant: entityinspector e8c2bb76

2021-10-20 17:59:31

greebo

Details Diff
0005613: Disable the tree view if we're in merge mode and have more than one entity selected Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector ac7464cf

2021-10-21 14:51:19

greebo

Details Diff
0005613: Intercept a crash when selecting worldspawn brushes Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File

DarkRadiant: entityinspector db329035

2021-10-21 15:04:19

greebo

Details Diff
0005613: Brush (worldspawn only) selection unit tests Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File
mod - test/resources/tdm/maps/entityinspector.map Diff File

DarkRadiant: entityinspector 1efa1620

2021-10-21 15:34:44

greebo

Details Diff
0005613: Brush (mixed entity) selection unit tests Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector d32be014

2021-10-21 17:06:55

greebo

Details Diff
0005613: Further expand the tests to check the event behaviour of the EntitySelection class. If the entity selection set is equivalent in between scans, the events should be silent. Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 3f57b7fd

2021-10-21 18:01:29

greebo

Details Diff
0005613: Reduce the amount of events fired when the actual set of entities changes or doesn't change Affected Issues
0005613
mod - libs/selection/EntitySelection.h Diff File

DarkRadiant: entityinspector 251819a2

2021-10-21 18:09:35

greebo

Details Diff
0005613: Add another scenario to the test case set that currently doesn't produce the desired results Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 857e0d34

2021-10-21 18:46:51

greebo

Details Diff
0005613: Add one more routine where a newly selected entity makes an existing set invisible in case it's lacking the keys Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File
mod - libs/selection/EntitySelection.h Diff File

DarkRadiant: entityinspector aaca0b1f

2021-10-21 18:57:55

greebo

Details Diff
0005613: One additional test case Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File

DarkRadiant: entityinspector d95a6ce1

2021-10-22 04:00:59

greebo

Details Diff
0005613: Implement EntityInspector::updatePrimitiveNumber() Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 3267a405

2021-10-22 04:52:43

greebo

Details Diff
0005613: Un-hook and move some code used by column sorting and help text update. Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: entityinspector 4369ea21

2021-10-22 06:39:23

greebo

Details Diff
0005613: In merge mode not real entities are selected. When hitting a single merge node, the Entity Inspector is fully refreshing its view on every selection change. Affected Issues
0005613
mod - libs/selection/EntitySelection.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 5a9d89b2

2021-10-22 09:54:02

greebo

Details Diff
0005613: Fix a crash that I ran into Affected Issues
0005613
mod - plugins/dm.editing/AIEditingPanel.cpp Diff File

DarkRadiant: entityinspector faee6e74

2021-10-22 09:54:44

greebo

Details Diff
0005613: Key value merge actions should be applying their target values to the affected entity node to allow for proper preview and bounds calculation during selection tests. Affected Issues
0005613
mod - libs/scene/merge/MergeAction.h Diff File
mod - libs/scene/merge/MergeActionNode.cpp Diff File

DarkRadiant: entityinspector 98c1af88

2021-10-22 10:36:24

greebo

Details Diff
0005613: Prevent crashing when selecting "Keep both entities" to resolve an action that originates from entity removal in the source map. Affected Issues
0005613
mod - libs/scene/merge/MergeLib.h Diff File
mod - radiant/ui/merge/MergeControlDialog.cpp Diff File

DarkRadiant: entityinspector 4fa64d94

2021-10-22 12:52:27

greebo

Details Diff
0005613: Fix display of removed and changed entity key values. On leaving merge mode the tree view needs to be cleared. Affected Issues
0005613
mod - include/imapmerge.h Diff File
mod - libs/scene/merge/MergeAction.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

DarkRadiant: entityinspector 1c98b06b

2021-10-22 12:57:32

greebo

Details Diff
0005613: Cleanup round Affected Issues
0005613
mod - radiant/ui/einspector/EntityInspector.cpp Diff File
mod - radiant/ui/einspector/EntityInspector.h Diff File

DarkRadiant: master 37297998

2021-10-22 17:42:08

greebo


Committer: angua Details Diff
0005613: Fix some non-shared spawnargs showing up in the entity inspector key value store Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File

DarkRadiant: master 74a47d19

2021-11-02 03:09:07

greebo

Details Diff
0005613: Remove wrong assertion Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File

DarkRadiant: master d1cddacc

2021-11-02 03:56:57

greebo

Details Diff
0005613: Add unit test covering another problem: origin key is appearing when moving a func_static with worldspawn primitives being selected too. The origin key should remain hidden since worldspawn doesn't have it. Affected Issues
0005613
mod - test/EntityInspector.cpp Diff File

DarkRadiant: master 611a200e

2021-11-02 04:04:02

greebo

Details Diff
0005613: Fix the behaviour when moving a func_static while worldspawn primitives are selected too Affected Issues
0005613
mod - libs/selection/CollectiveSpawnargs.h Diff File

Issue History

Date Modified Username Field Change
13.05.2021 19:55 BrendonChung New Issue
13.05.2021 19:55 BrendonChung File Added: entityinspector.png
14.05.2021 04:02 greebo Status new => confirmed
20.05.2021 19:51 orbweaver Note Added: 0014036
15.10.2021 04:24 greebo Assigned To => greebo
15.10.2021 04:24 greebo Status confirmed => assigned
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 0874508e
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 24b0da82
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 5599d144
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector a2cedef4
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector bcfac235
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 585880ae
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector d122fef5
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 20b508ef
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector f51e5371
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector c95041f2
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 7341bdcf
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector cc265469
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 40be3e61
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector 54be9e99
16.10.2021 11:29 greebo Changeset attached => DarkRadiant entityinspector b4b6c10d
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 09905ebc
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 2f1d9859
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector e275e9dd
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector a712aa77
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 0429c9cc
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector f060e712
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 6f1e2918
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 2effcb45
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 66bd95d4
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 0d15e808
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector 27109f78
17.10.2021 07:31 greebo Changeset attached => DarkRadiant entityinspector af12115a
17.10.2021 15:14 greebo Changeset attached => DarkRadiant entityinspector e610aa45
17.10.2021 15:14 greebo Changeset attached => DarkRadiant entityinspector b268207e
17.10.2021 15:14 greebo Changeset attached => DarkRadiant entityinspector f349ecc5
17.10.2021 16:47 greebo Changeset attached => DarkRadiant entityinspector b9d53176
17.10.2021 16:47 greebo Changeset attached => DarkRadiant entityinspector efcf6c7d
17.10.2021 17:39 greebo Changeset attached => DarkRadiant entityinspector 464ec1fc
17.10.2021 17:39 greebo Changeset attached => DarkRadiant entityinspector fb0ed634
17.10.2021 18:43 greebo Changeset attached => DarkRadiant entityinspector 0a96b48c
18.10.2021 18:15 greebo Changeset attached => DarkRadiant entityinspector b7cba693
18.10.2021 18:15 greebo Changeset attached => DarkRadiant entityinspector 56190d44
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector e8c2bb76
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector db329035
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector ac7464cf
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector 1efa1620
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector d32be014
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector 3f57b7fd
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector 251819a2
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector 857e0d34
21.10.2021 18:58 greebo Changeset attached => DarkRadiant entityinspector aaca0b1f
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector d95a6ce1
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector 3267a405
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector 4369ea21
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector 5a9d89b2
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector faee6e74
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector 98c1af88
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector 4fa64d94
22.10.2021 13:10 greebo Changeset attached => DarkRadiant entityinspector 1c98b06b
22.10.2021 13:45 greebo Target Version => 2.14.0
22.10.2021 13:45 greebo Description Updated
22.10.2021 13:45 greebo Status assigned => resolved
22.10.2021 13:45 greebo Resolution open => fixed
22.10.2021 13:45 greebo Fixed in Version => 2.14.0
22.10.2021 13:45 greebo Note Added: 0014443
22.10.2021 13:45 greebo File Added: grafik.png
22.10.2021 17:45 angua Changeset attached => DarkRadiant master 37297998
02.11.2021 03:08 greebo Changeset attached => DarkRadiant renderer 775f8d7f
02.11.2021 03:08 greebo Changeset attached => DarkRadiant renderer 48d06331
02.11.2021 03:10 greebo Changeset removed DarkRadiant renderer 775f8d7f =>
02.11.2021 03:10 greebo Changeset removed DarkRadiant renderer 48d06331 =>
02.11.2021 04:04 greebo Changeset attached => DarkRadiant master 74a47d19
02.11.2021 04:04 greebo Changeset attached => DarkRadiant master d1cddacc
02.11.2021 04:04 greebo Changeset attached => DarkRadiant master 611a200e
20.11.2021 17:29 greebo Relationship added related to 0005813