View Issue Details

IDProjectCategoryView StatusLast Update
0005814DarkRadiantGUIpublic21.11.2021 16:13
ReporterDragofer Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.13.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0005814: Spawnarg type icon not shown for inherited properties
DescriptionNone of the spawnargs in the "inherited properties" section of the entity inspector are shown with their type icons (i.e. T for text spawnargs, 4 coloured squares for colour spawnargs, blue list for def spawnargs).

It would be quite useful if inherited properties, too, showed these icons since there are usually a lot of them, so it'd help with figuring out each one's purpose at a glance.
TagsNo tags attached.

Relationships

related to 0005813 resolvedgreebo Spawnarg types and tooltips not reliably inherited in entityDefs 

Activities

There are no notes attached to this issue.

Related Changesets

DarkRadiant: master 7184e726

2021-11-21 15:53:01

greebo

Details Diff
0005814: Show icons for inherited properties Affected Issues
0005814
mod - libs/wxutil/dataview/TreeViewItemStyle.h Diff File
mod - radiant/ui/einspector/EntityInspector.cpp Diff File

Issue History

Date Modified Username Field Change
18.11.2021 16:51 Dragofer New Issue
20.11.2021 16:42 greebo Status new => acknowledged
21.11.2021 15:52 greebo Relationship added related to 0005813
21.11.2021 15:52 greebo Status acknowledged => confirmed
21.11.2021 16:13 greebo Changeset attached => DarkRadiant master 7184e726
21.11.2021 16:13 greebo Target Version => 2.14.0
21.11.2021 16:13 greebo Assigned To => greebo
21.11.2021 16:13 greebo Status confirmed => assigned
21.11.2021 16:13 greebo Status assigned => resolved
21.11.2021 16:13 greebo Resolution open => fixed
21.11.2021 16:13 greebo Fixed in Version => 2.14.0