View Issue Details

IDProjectCategoryView StatusLast Update
0005816The Dark ModGraphicspublic06.01.2022 12:47
Reporterstgatilov Assigned Toduzenko  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionSVN 
Target VersionTDM 2.10Fixed in VersionTDM 2.10 
Summary0005816: Volumetric lights (aka "god rays")
DescriptionThat's the case when viewer sees the whole light volume because it becomes brighter than surroundings.
This is caused by the dust in the air being lit but the light.
Additional InformationThe discussion on forums sees to be here:
  https://forums.thedarkmod.com/index.php?/topic/19659-feature-request-emissive-materialsvolumetric-lights/#comment-427762
  https://forums.thedarkmod.com/index.php?/topic/21155-volumetric-light-discussion/
TagsNo tags attached.

Relationships

related to 0004888 resolvedstgatilov Terrible precision in light frustums 
related to 0005815 feedbackstgatilov Projected lights behavior has changed since 2.08 
related to 0005850 new Volumetric lights: render to texture then blur 

Activities

stgatilov

stgatilov

12.12.2021 04:07

administrator   ~0014584

Last edited: 12.12.2021 04:07

Pasting here related commits.

Main development:
  r9616 Volumetric light brought to life, still incomplete
  r9617 Volumetric shader nVidia fix, debug WIP
  r9618 Volumetric shader: simple version WIP
  r9628 Volumetric shader: bugfix
  r9637 Volumetric lights: support for stencil path (shadows ignored), LOD bias
  r9638 Volumetric lights: disable scissor test
  r9639 Volumetric lights: nVidia compatibility

Fixes due to review (https://forums.thedarkmod.com/index.php?/topic/21155-volumetric-light-discussion/):
  r9672 Reimplemented ray-polytope intersection, multiply average by distance within light volume, render backfaces only.
  r9673 Use ray parameters instead of 3D points.
  r9674 Simplified handling of depth texture.
  r9675 Show full-white frustum when #samples = 0.
  r9678 Now uniforms are used in standard means in volumetric lights.
  r9684 Oops... fixed volumetric lights on stencil shadow path (and noshadows too probably).
  r9691 Added "volumetric_dust" spawnarg for lights (only has effect on volumetric light).

The joy of dithering:
  r9692 Volumetric lights are now randomly sampled, number of samples can no longer be set in material.
  r9693 Volumetric sampling: use less random random =)
  r9694 Use Bayer matrix for randomization.
  r9701 r_volumetricRandomize renamed ot r_volumetricDither.
stgatilov

stgatilov

26.12.2021 08:00

administrator   ~0014608

Changed the way how volumetric light is enabled:
  r9742. Volumetric light is triggered by "volumetric_light" spawnarg instead of "volumetricLight" material keyword.
stgatilov

stgatilov

06.01.2022 12:47

administrator   ~0014647

Some more commits:
  r9751. Volumetric lights respect noshadows setting, and don't affect lightgem.
  r9762. Added support for "volumetric_noshadows" spawnarg.
  r9763. Also disable volumetric light with volumetric_noshadows 0 if user has disabled sampling.
  r9781. Fixed saving/loading volumetric lights.

Issue History

Date Modified Username Field Change
19.11.2021 04:39 stgatilov New Issue
19.11.2021 04:39 stgatilov Status new => assigned
19.11.2021 04:39 stgatilov Assigned To => duzenko
19.11.2021 04:40 stgatilov Relationship added related to 0004888
19.11.2021 04:40 stgatilov Relationship added related to 0005815
19.11.2021 04:42 stgatilov Additional Information Updated
19.11.2021 05:14 stgatilov Additional Information Updated
12.12.2021 04:07 stgatilov Note Added: 0014584
12.12.2021 04:07 stgatilov Note Edited: 0014584
12.12.2021 04:07 stgatilov Note Edited: 0014584
12.12.2021 04:08 stgatilov Status assigned => resolved
12.12.2021 04:08 stgatilov Resolution open => fixed
12.12.2021 04:08 stgatilov Fixed in Version => TDM 2.10
21.12.2021 17:17 stgatilov Relationship added related to 0005850
26.12.2021 08:00 stgatilov Note Added: 0014608
06.01.2022 12:47 stgatilov Note Added: 0014647