View Issue Details

IDProjectCategoryView StatusLast Update
0005968DarkRadiantGeneralpublic06.06.2022 05:08
ReporterFrost_Salamander Assigned Togreebo  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version3.0.0 
Target Version3.0.0Fixed in Version3.0.0 
Summary0005968: 3.0.0pre7: origin of player start entity misaligned
DescriptionThe origin of the player start entity is misaligned. It seems to be shifted vertically so it is flush with the top of the entity. If you place it in a room, when starting the game the player will frequently be stuck in the ceiling and you have to noclip to get out.

Attached screenshots to illustrate.
Steps To ReproduceAdd start entity to map, and select to see the strange origin placement.
TagsNo tags attached.

Activities

Frost_Salamander

Frost_Salamander

04.06.2022 23:45

reporter  

player_start_origin1.PNG (105,112 bytes)   
player_start_origin1.PNG (105,112 bytes)   
player_start_origin2.PNG (6,103 bytes)   
player_start_origin2.PNG (6,103 bytes)   

Related Changesets

DarkRadiant: master c1190bfc

2022-06-06 03:13:22

greebo

Details Diff
0005968: Revert the center change of the RenderableEntityBox from d3534fe9, turns out the fixed AABB calculation is enough to place the box where it's supposed to be. Affected Issues
0005968
mod - include/version.h Diff File
mod - radiantcore/entity/generic/GenericEntityNode.cpp Diff File

Issue History

Date Modified Username Field Change
04.06.2022 23:45 Frost_Salamander New Issue
04.06.2022 23:45 Frost_Salamander File Added: player_start_origin1.PNG
04.06.2022 23:45 Frost_Salamander File Added: player_start_origin2.PNG
05.06.2022 16:43 greebo Status new => confirmed
06.06.2022 03:11 greebo Assigned To => greebo
06.06.2022 03:11 greebo Status confirmed => assigned
06.06.2022 03:14 greebo Status assigned => resolved
06.06.2022 03:14 greebo Resolution open => fixed
06.06.2022 03:14 greebo Fixed in Version => 3.0.0
06.06.2022 03:14 greebo Changeset attached => DarkRadiant master c1190bfc
06.06.2022 05:08 greebo Product Version => 3.0.0
06.06.2022 05:08 greebo Target Version => 3.0.0