View Issue Details

IDProjectCategoryView StatusLast Update
0000096DarkRadiantMap Editingpublic28.02.2007 21:23
ReporterSneaksieDave Assigned Togreebo  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.8.1 
Fixed in Version0.9.0 
Summary0000096: Locked axis resize mode
DescriptionIn the past few days of using DR, I've become a big fan of the locked axis translation. Hopefully when entry 0000054 is addressed, although that will enable dragging anywhere, the axis-locked translation arrows will still exist/function.

An annoying common thing in DoomEd (as well as DR), when you are trying to resize multiple brushes (for instance, lowering the four walls of a room) down at the same time, any side to side movement at all will start resizing brushes in a horizontal direction - those away from the move getting thinner, those in the direction of the move getting thicker - which invariably leads to ctrl-z, deselect, and then resizing each one individually.

It'd be great if there was some 'sub-mode' to Q-resize mode, where axes could be locked.
TagsNo tags attached.

Activities

orbweaver

orbweaver

10.02.2007 21:34

developer   ~0000078

This sounds like the Blender middle-click functionality which locks an operation to the local axis.
greebo

greebo

11.02.2007 07:37

administrator   ~0000079

Or pressing any modifier while dragging things around (which I would prefer, because it's the way many other applications do it, save Blender ;-))
SneaksieDave

SneaksieDave

11.02.2007 17:03

developer   ~0000085

DoomEd handles it with the X Y Z buttons at the top, for scale X, scale Y, scale Z. Even a shortcut to this type of functionality would be very welcome; alt-x, alt-y, alt-z, for example.
greebo

greebo

28.02.2007 10:48

administrator   ~0000276

Last edited: 28.02.2007 10:48

The mapper can hold down SHIFT during an operation to constrain the movement to the major axis. This applies to all operations, not just the scale manipulations.

SneaksieDave

SneaksieDave

28.02.2007 21:23

developer   ~0000292

very nice >:)

Issue History

Date Modified Username Field Change
10.02.2007 19:16 SneaksieDave New Issue
10.02.2007 19:16 SneaksieDave Severity minor => feature
10.02.2007 21:34 orbweaver Note Added: 0000078
10.02.2007 21:34 orbweaver Status new => acknowledged
11.02.2007 07:37 greebo Note Added: 0000079
11.02.2007 17:03 SneaksieDave Note Added: 0000085
28.02.2007 10:48 greebo Status acknowledged => resolved
28.02.2007 10:48 greebo Fixed in Version => latest SVN
28.02.2007 10:48 greebo Resolution open => fixed
28.02.2007 10:48 greebo Assigned To => greebo
28.02.2007 10:48 greebo Note Added: 0000276
28.02.2007 10:48 greebo Note Edited: 0000276
28.02.2007 21:23 SneaksieDave Status resolved => closed
28.02.2007 21:23 SneaksieDave Note Added: 0000292