View Issue Details

IDProjectCategoryView StatusLast Update
0003486The Dark ModAIpublic25.05.2020 22:11
ReporterSpringheel Assigned ToSpringheel  
PrioritynormalSeveritynormalReproducibilityalways
Status resolvedResolutionopen 
Product VersionTDM 2.00 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0003486: Completed Werebeast needed
DescriptionMesh and a few animations are done...need to find out which bone is the "origin" bone and rename it. Also need to find out which bones should be in the "leg" and "torso" channels.


http://forums.thedarkmod.com/topic/14066-needed-for-standalone-animated-werebeast/page__pid__315112__st__75#entry315112
TagsNo tags attached.

Relationships

parent of 0005184 new Issues with new manbeast/werebeast/zombie assets 
parent of 0005010 new Broken items noticed by e.g. animals 
Not all the children of this issue are yet resolved or closed.

Activities

Springheel

Springheel

10.08.2013 21:15

administrator   ~0005994

This isn't going to make it in for 2.0, so check and make sure proper "excluded" lines are set in maps file.
grayman

grayman

08.04.2014 19:52

administrator   ~0006516

I guess this won't make it for 2.02, so can it be moved to 2.03?

(We need a 2.03 slot, btw.)
Springheel

Springheel

19.02.2015 23:40

administrator   ~0007426

Last edited: 20.02.2015 17:26

View 2 revisions

Not sure the most recent version was ever tested. Try to establish what needs to be done here.

This is the latest link: http://forums.thedarkmod.com/topic/14066-needed-for-standalone-animated-werebeast/?p=316764

Springheel

Springheel

20.10.2018 20:00

administrator   ~0010792

The werebeast is further along than I remembered. I was playing around with the version Obsttorte worked on, and he seems to be behaving reasonably well--enough to walk up and kill me with a melee attack. He also appears to have a working ragdoll. His animations are limited though, and he currently can see me through the back of his head.

Ok, so currently the werebeast has only 3 animations:

walkcycle
melee attack
idle

In order to be fully usable, he would need, at a minimum:

runcycle
search
pain
turn
An alternate melee attack would probably be helpful too, even if it's just a mirrored left-to-right.

Another thing is walk-ik--at the moment he floats when walking up and down stairs. Unfortunately, his bones are all helpfully labelled "bone00x", so tracking down the right bones to control the legs might be a chore.
nbohr1more

nbohr1more

25.05.2020 22:06

developer   ~0012554

Last edited: 25.05.2020 22:11

View 2 revisions

Werebeast will be in 2.08. Any remaining issues can be tracked in new trackers such as 0005184

Issue History

Date Modified Username Field Change
13.07.2013 21:28 Springheel New Issue
13.07.2013 21:29 Springheel Description Updated View Revisions
10.08.2013 21:15 Springheel Note Added: 0005994
18.08.2013 00:31 Springheel Target Version TDM 2.00 => TDM 2.01
19.10.2013 20:59 Springheel Target Version TDM 2.01 => TDM 2.02
08.04.2014 19:52 grayman Note Added: 0006516
22.04.2014 14:40 Springheel Target Version TDM 2.02 => TDM 2.03
21.11.2014 20:33 Springheel Target Version TDM 2.03 =>
19.02.2015 23:40 Springheel Assigned To => Springheel
19.02.2015 23:40 Springheel Status new => assigned
19.02.2015 23:40 Springheel Note Added: 0007426
20.02.2015 17:26 Springheel Note Edited: 0007426 View Revisions
11.08.2017 18:00 Springheel Assigned To Springheel =>
20.10.2018 19:59 Springheel Assigned To => Springheel
20.10.2018 19:59 Springheel Status assigned => new
20.10.2018 19:59 Springheel Assigned To Springheel =>
20.10.2018 20:00 Springheel Note Added: 0010792
25.05.2020 21:59 nbohr1more Assigned To => Obstler
25.05.2020 21:59 nbohr1more Reproducibility have not tried => always
25.05.2020 21:59 nbohr1more Status new => resolved
25.05.2020 21:59 nbohr1more Fixed in Version => TDM 2.08
25.05.2020 21:59 nbohr1more Target Version => TDM 2.08
25.05.2020 22:02 nbohr1more Assigned To Obstler => Springheel
25.05.2020 22:06 nbohr1more Note Added: 0012554
25.05.2020 22:08 nbohr1more Relationship added parent of 0005184
25.05.2020 22:11 nbohr1more Relationship added parent of 0005010
25.05.2020 22:11 nbohr1more Note Edited: 0012554 View Revisions