View Issue Details

IDProjectCategoryView StatusLast Update
0005184The Dark ModModelspublic28.06.2020 18:05
ReporterDragofer Assigned To 
PrioritynormalSeveritynormalReproducibilityalways
Status newResolutionreopened 
Product VersionTDM 2.08 
Target VersionTDM 2.09Fixed in VersionTDM 2.08 
Summary0005184: Issues with new manbeast/werebeast/zombie assets
DescriptionAs per https://forums.thedarkmod.com/index.php?/topic/20291-beta-testing-208/&do=findComment&comment=444834:

Unfixed:
- for every atdm:ai_undead_zombie_clothed01 in the map, 2 lines get posted to the console about unknown copy_joint headcontrol and neckcontrol. They have 4 inherited copy_joint spawnargs, whereas other zombies and all other AIs I checked only have 2. So far I couldn't find where those extra spawnargs came from.

Fixed but not part of 2.08:
- zombies: zombie alt animations entity was defined twice
- zombies: zombie alt animations entity def was missing snd_rustle_run (caused console spam) and had a duplicate line (anim_rate_manbeast_idle_armswing)
- werebeast: mesh exists twice, (2nd one is models/md5/chars/monsters/werebeast/werebeast_mesh - Kopie.md5mesh)
- manbeast: remove ghost version of the head
- manbeast: include the manbeast mask as an exotic loot item (currently head def is still commented out, needs more work, see comments)
- manbeast: removed all files of the first vocal set because it was unfinished and renamed the files of the 2nd vocal set to take the place of the 1st.
- manbeast: LOD stages: the base model has considerably fewer polys than the first LOD stage and no shadowmesh at all, and a few minor quibbles when it comes to which stage has which adornments. Much enhanced LOD versions submitted by kingsal.
- manbeast: hair material shows up brighter than it should be in SVN
- manbeast: reduced duplicate material counts

Fixed in 2.08:
- zombies: the entities atdm:ai_undead_zombie_alt_animations and atdm:ai_undead_zombie_clothed01 are missing models, so I see just a "shader not found" box
- manbeast: head didn't follow naming conventions for heads
- manbeast: removed ghost version since it wasn't made for regular gameplay
- manbeast: in the "Create entity" list, a new top-level "weapons" folder has been created next to the existing "Weapons" folder
- manbeast: in the "Create entity" list, the "manbeast" folder name isn't capitalised
- manbeast: in the "Create entity" list, a new top-level folder "creatures" contains the heads, vocal set and ragdoll, which breaks conventions
   i) heads are usually in Internal/AI
   ii) vocal sets are usually in AI/Internal/Vocal Sets
   iii) ragdolls are usually in Ragdolls/Bodies
TagsNo tags attached.

Relationships

child of 0005204 resolvedDragofer 2.08 beta issues with new assets 
child of 0003486 resolvedSpringheel Completed Werebeast needed 

Activities

Springheel

Springheel

03.05.2020 20:55

administrator   ~0012452

It was a stray bracket that caused the problem.

He's missing footstep sounds and several animations, but can be put into a map.

Trunk revision #15919 & 15920
Dragofer

Dragofer

06.06.2020 12:01

developer   ~0012597

There are still numerous issues on this list that haven't been resolved (i.e. werebeast mesh existing twice, missing editor images)
Dragofer

Dragofer

16.06.2020 11:08

developer   ~0012616

#15953 Fixed most of the issues listed, don't have the setup to fix the materials on the .md5meshes.

I noticed that some of the manbeast assets didn't make it over from Volta 2 (1 vocal set, ghost variant (only the model), LOD models - see description for more details). I take it that was intentional for the most part?
nbohr1more

nbohr1more

18.06.2020 05:47

developer   ~0012619

Is there anything left to do here that would block a 2.08 release?

Can this be closed or moved to 2.09?
Dragofer

Dragofer

18.06.2020 07:29

developer   ~0012620

The only major point is that there's only 1 out of 2 vocal sets. Would be worth getting some input from Springheel from to see if there were problems with the other vocal set, before deciding on whether to release 2.08 with one or both sets.
kingsal

kingsal

19.06.2020 10:10

reporter   ~0012621

Ill send you guys some better LODs. I rushed them and never went back in to fix them. The ghost version is only used in cauldron as a scripted sequence so you can delete that. I started a second vocal set but never got around to finishing it. Also yea, they have more limited vocal set in general.
Dragofer

Dragofer

20.06.2020 10:47

developer   ~0012623

Last edited: 20.06.2020 11:35

View 3 revisions

#15959: Manbeasts: deleted unfinished 1st vocal set and renamed all files of 2nd vocal set to take the place of the 1st. Much better LOD meshes submitted by kingsal with reduced duplicate materials. Moved movement-related soundshaders from tdm_ai_monster_manbeast.sndshd into tdm_sfx_movement.sndshd. Manbeast hair was showing up too bright ingame because of an excess diffusemap line.
Dragofer

Dragofer

20.06.2020 11:29

developer   ~0012624

#15960: Zombie alt animations: entity was defined twice, entity def was missing snd_rustle_run spawnarg (caused console spam) and had a duplicated line (anim_rate_manbeast_idle_armswing).
Dragofer

Dragofer

20.06.2020 13:24

developer   ~0012626

#15962: Added kingsal's manbeast mask as an exotic loot item and deleted a redundant manbeast head. The head def with the mask is still commented out because it needs more work (i.e. make them notice when their mask gets taken off their faces or make the mask unfrobable as long as its wearer is conscious).
Dragofer

Dragofer

20.06.2020 19:22

developer   ~0012627

#15963: Manbeast loot mask entity defs sorted out (2 versions: loot & wearable loot), masked manbeast head has been uncommented. While I was working on monsters, removed the editor_usage claiming the fire elemental is still WIP.
Dragofer

Dragofer

21.06.2020 08:31

developer   ~0012630

#15966: Tidied up manbeast mask texture files.
Dragofer

Dragofer

21.06.2020 08:31

developer   ~0012631

All issues fixed except for a minor one that can be addressed later.
Dragofer

Dragofer

28.06.2020 08:46

developer   ~0012641

The fixes tracked in this ticket didn't become part of 2.08, so we have the situation that we have released assets that should've been deleted or renamed. There are 2 options from here:
A) merge all the revs from this ticket into 2.09 and manually fix any missions that reference specific assets that no longer exist
B) start from scratch with fixing the monster characters, this time keeping compatibility with the unfixed version of the assets

I'll look into getting a list of assets that were deleted or renamed in these revs for option A.
Dragofer

Dragofer

28.06.2020 18:05

developer   ~0012642

Rev 15953 actually made it into the release build, so a part of the list of issues has already been resolved (mainly adjustment to folder/naming conventions).

Issue History

Date Modified Username Field Change
18.03.2020 13:05 Dragofer New Issue
18.03.2020 23:43 Dragofer Reproducibility N/A => always
18.03.2020 23:43 Dragofer Target Version => TDM 2.08
02.04.2020 06:39 stgatilov Relationship added related to 0004970
02.04.2020 06:39 stgatilov Relationship deleted related to 0004970
02.04.2020 06:39 stgatilov Relationship added related to 0004970
02.04.2020 06:40 stgatilov Relationship deleted related to 0004970
03.05.2020 19:35 Springheel Assigned To => Springheel
03.05.2020 19:35 Springheel Status new => assigned
03.05.2020 20:55 Springheel Note Added: 0012452
03.05.2020 20:55 Springheel Status assigned => feedback
20.05.2020 17:07 nbohr1more Status feedback => resolved
20.05.2020 17:07 nbohr1more Resolution open => fixed
20.05.2020 17:07 nbohr1more Fixed in Version => TDM 2.08
25.05.2020 21:45 nbohr1more Relationship added child of 0005204
25.05.2020 22:08 nbohr1more Relationship added child of 0003486
06.06.2020 12:01 Dragofer Status resolved => feedback
06.06.2020 12:01 Dragofer Resolution fixed => reopened
06.06.2020 12:01 Dragofer Note Added: 0012597
14.06.2020 18:40 Dragofer Description Updated View Revisions
16.06.2020 08:37 Dragofer Description Updated View Revisions
16.06.2020 08:37 Dragofer Description Updated View Revisions
16.06.2020 09:10 Dragofer Description Updated View Revisions
16.06.2020 11:03 Dragofer Description Updated View Revisions
16.06.2020 11:08 Dragofer Note Added: 0012616
16.06.2020 11:08 Dragofer Status feedback => assigned
16.06.2020 11:13 Dragofer Description Updated View Revisions
16.06.2020 11:18 Dragofer Description Updated View Revisions
18.06.2020 05:47 nbohr1more Note Added: 0012619
18.06.2020 07:29 Dragofer Note Added: 0012620
19.06.2020 09:45 Dragofer Assigned To Springheel => Dragofer
19.06.2020 09:45 Dragofer Description Updated View Revisions
19.06.2020 10:10 kingsal Note Added: 0012621
19.06.2020 10:14 Dragofer Description Updated View Revisions
19.06.2020 10:33 Dragofer Description Updated View Revisions
19.06.2020 12:35 Dragofer Description Updated View Revisions
20.06.2020 10:42 Dragofer Description Updated View Revisions
20.06.2020 10:47 Dragofer Note Added: 0012623
20.06.2020 10:48 Dragofer Note Edited: 0012623 View Revisions
20.06.2020 10:48 Dragofer Description Updated View Revisions
20.06.2020 11:16 Dragofer Description Updated View Revisions
20.06.2020 11:29 Dragofer Note Added: 0012624
20.06.2020 11:31 Dragofer Description Updated View Revisions
20.06.2020 11:35 Dragofer Note Edited: 0012623 View Revisions
20.06.2020 13:24 Dragofer Note Added: 0012626
20.06.2020 13:27 Dragofer Description Updated View Revisions
20.06.2020 19:22 Dragofer Note Added: 0012627
21.06.2020 08:31 Dragofer Note Added: 0012630
21.06.2020 08:31 Dragofer Status assigned => resolved
21.06.2020 08:31 Dragofer Resolution reopened => fixed
21.06.2020 08:31 Dragofer Note Added: 0012631
28.06.2020 08:39 Dragofer Assigned To Dragofer =>
28.06.2020 08:39 Dragofer Status resolved => feedback
28.06.2020 08:39 Dragofer Resolution fixed => reopened
28.06.2020 08:39 Dragofer Assigned To => Dragofer
28.06.2020 08:39 Dragofer Status feedback => new
28.06.2020 08:43 Dragofer Target Version TDM 2.08 => TDM 2.09
28.06.2020 08:46 Dragofer Note Added: 0012641
28.06.2020 08:51 Dragofer Summary Issues with new manbeast/werebeast/zombie assets (SVN 2.08) => Issues with new manbeast/werebeast/zombie assets
28.06.2020 08:51 Dragofer Description Updated View Revisions
28.06.2020 08:56 Dragofer Assigned To Dragofer =>
28.06.2020 18:05 Dragofer Description Updated View Revisions
28.06.2020 18:05 Dragofer Note Added: 0012642