View Issue Details

IDProjectCategoryView StatusLast Update
0004107The Dark ModDef / Setuppublic14.02.2019 14:45
ReporterSpringheelAssigned ToSTiFU 
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionTDM 2.03 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0004107: Need too much room to drop rag dolls
DescriptionRight now you can't drop them places it looks like you should be able to. I adjusted this for dropping Sykes; perhaps a inversely change would be worth exploring.
TagsNo tags attached.

Relationships

related to 0003607 resolvedSTiFU Add dip to shouldering bodies 
related to 0001932 suspended Gameplay balance between shouldering and dragging of bodies / Add shouldering ragdoll 

Activities

nbohr1more

nbohr1more

17.10.2017 15:17

developer   ~0009513

2.07 ?
Springheel

Springheel

21.01.2019 03:00

administrator   ~0011457

Last edited: 21.01.2019 03:01

View 2 revisions

Hmm. What's interesting is that the even if the player has plenty of space in front of them, if they are standing beside a wall, they will not be able to drop a ragdoll. Take one step away from the wall and then dropping is possible.

So the problem is not really connected to how much space is in front of the player--the ragdolls will actually turn sideways if there is not enough space to lay flat facing away from the player. The problem is when the player is in a thin area with not enough space to the left and right, like a thin hallway or a doorway. This isn't intuitive to the player, who will only be looking at the space in front of them.

I'm not sure what in the code makes that happen.

Springheel

Springheel

22.01.2019 22:12

administrator   ~0011477

I'm going to unassign this from myself, as I've done all I can with the def values.
STiFU

STiFU

14.02.2019 14:45

developer   ~0011595

Rev. 7958: The code will now try to drop the rag doll in multiple directions away from the player instead of just in front of him.

You can specify the range of angles from -cv_pm_shoulderDrop_maxAngle to +cv_pm_shoulderDrop_maxAngle and respective angle increments cv_pm_shoulderDrop_angleIncrement at which this test is performed.

I have put default values of
cv_pm_shoulderDrop_maxAngle = +/- 100 (droping to left and right side)
cv_pm_shoulderDrop_angleIncrement = +/- 15

As a bonus, this also helps with droping inventory items to your hands while standing close to a wall.

Issue History

Date Modified Username Field Change
26.02.2015 19:07 Springheel New Issue
26.02.2015 19:07 Springheel Status new => assigned
26.02.2015 19:07 Springheel Assigned To => Springheel
08.01.2016 21:36 Springheel Target Version TDM 2.04 => TDM 2.05
25.11.2016 13:58 grayman Target Version TDM 2.05 => TDM 2.06
17.10.2017 15:17 nbohr1more Note Added: 0009513
17.10.2017 20:43 Springheel Target Version TDM 2.06 =>
21.01.2019 03:00 Springheel Note Added: 0011457
21.01.2019 03:01 Springheel Note Edited: 0011457 View Revisions
22.01.2019 22:11 Springheel Relationship added related to 0003588
22.01.2019 22:11 Springheel Relationship deleted related to 0003588
22.01.2019 22:11 Springheel Relationship added related to 0003607
22.01.2019 22:12 Springheel Note Added: 0011477
22.01.2019 22:12 Springheel Assigned To Springheel =>
13.02.2019 16:44 STiFU Relationship added related to 0001932
13.02.2019 17:12 STiFU Assigned To => STiFU
14.02.2019 14:45 STiFU Note Added: 0011595
14.02.2019 14:45 STiFU Status assigned => resolved
14.02.2019 14:45 STiFU Resolution open => fixed
14.02.2019 14:45 STiFU Fixed in Version => TDM 2.08
14.02.2019 14:45 STiFU Target Version => TDM 2.08