View Issue Details

IDProjectCategoryView StatusLast Update
0003607The Dark ModDef / Setuppublic13.02.2019 14:33
ReporterSpringheel Assigned ToSTiFU  
PrioritynormalSeveritynormalReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0003607: Add dip to shouldering bodies
DescriptionWhen the player shoulders a body, a short rotation down of the POV, to simulate bending to pick up the body, would add something. Should be easy to accomplish.
TagsNo tags attached.

Relationships

related to 0001174 closed Pick up animation for lifting a body 
related to 0003588 resolvedSTiFU Player can jump with body after loading game 
related to 0001932 suspended Gameplay balance between shouldering and dragging of bodies / Add shouldering ragdoll 
related to 0004107 resolvedSTiFU Need too much room to drop rag dolls 

Activities

STiFU

STiFU

04.01.2019 19:36

developer   ~0011244

What if the player already looks at the body? A rotation down would look weird then I guess. Maybe we should just translate the view a little bit down, simulating a kneel down and pick-up?
Springheel

Springheel

05.01.2019 00:45

administrator   ~0011245

Last edited: 05.01.2019 14:30

View 2 revisions

Translating down a bit might do the trick.

Since we were speaking of sounds earlier, here's another place we might want an environmental sound in addition to the grunt--perhaps playing whatever "body collapse" sound goes with the ragdoll in question, at a lower volume?

edit: actually, a more appropriate one would probably be whatever movement rustle is played while the AI is moving.

STiFU

STiFU

23.01.2019 06:57

developer   ~0011480

Note to self: Make sure this viewport animation does not interfere with other viewport animations like leaning.
STiFU

STiFU

13.02.2019 14:33

developer   ~0011585

Rev. 7953 adds viewport animation, rev. 7954 adds playing of rustle sounds.

The latter are pretty quiet, but there doesn't seem to be an option to increase volume from within the code. In order to actually notice the rustles, I play them numerous times while the shouldering animation plays out.

Issue History

Date Modified Username Field Change
19.11.2013 00:15 Springheel New Issue
19.11.2013 00:15 Springheel Status new => assigned
19.11.2013 00:15 Springheel Assigned To => Springheel
17.09.2017 00:58 Springheel Assigned To Springheel =>
16.10.2017 20:20 nbohr1more Relationship added related to 0001174
24.11.2017 16:45 grayman Status assigned => new
04.01.2019 19:36 STiFU Note Added: 0011244
05.01.2019 00:45 Springheel Note Added: 0011245
05.01.2019 14:30 Springheel Note Edited: 0011245 View Revisions
22.01.2019 22:09 Springheel Assigned To => STiFU
22.01.2019 22:09 Springheel Status new => assigned
22.01.2019 22:10 Springheel Relationship added related to 0003588
22.01.2019 22:11 Springheel Relationship added related to 0004107
22.01.2019 22:14 Springheel Relationship added related to 0001932
22.01.2019 22:15 Springheel Relationship added related to 0004235
22.01.2019 22:18 Springheel Relationship deleted related to 0004235
23.01.2019 06:14 STiFU Target Version => TDM 2.08
23.01.2019 06:57 STiFU Note Added: 0011480
13.02.2019 14:33 STiFU Note Added: 0011585
13.02.2019 14:33 STiFU Status assigned => resolved
13.02.2019 14:33 STiFU Resolution open => fixed
13.02.2019 14:33 STiFU Fixed in Version => TDM 2.08