View Issue Details

IDProjectCategoryView StatusLast Update
0000431DarkRadiantMap Editingpublic13.03.2009 12:33
Reportertels Assigned Togreebo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version0.9.7Fixed in Version0.9.7 
Summary0000431: cloning path entities creates broken connections
Description* Create two path_corner entities and link them together.
* select the first of them and press SPACE to clone it

The clone will have a target0 field, too, but the entity name in that field is just the incremented name of the original, and thus points to a non-existing entity.

On cloning, targetX fields should be removed from the clone.
TagsNo tags attached.

Relationships

duplicate of 0000385 closedgreebo Don't increment target fields on duplicated entities 
related to 0000257 closedgreebo Bad name increment for entities after saving 
child of 0000635 closedgreebo Fix or rewrite Namespace module 

Activities

tels

tels

11.11.2007 11:30

developer   ~0000863

This actually happens for all entities, not just paths. Sorry for the incorrect subject :)

Issue History

Date Modified Username Field Change
11.11.2007 11:29 tels New Issue
11.11.2007 11:30 tels Note Added: 0000863
11.11.2007 12:46 greebo Status new => acknowledged
11.11.2007 12:46 greebo Relationship added duplicate of 0000385
07.12.2007 09:11 greebo Relationship added related to 0000257
08.04.2008 18:45 greebo Relationship added child of 0000635
27.06.2008 21:38 greebo Status acknowledged => assigned
27.06.2008 21:38 greebo Assigned To => greebo
27.06.2008 21:39 greebo Status assigned => resolved
27.06.2008 21:39 greebo Fixed in Version => 0.9.7
27.06.2008 21:39 greebo Resolution open => fixed
27.06.2008 21:39 greebo Projection none => redesign
27.06.2008 21:39 greebo ETA none => < 1 month
27.06.2008 21:39 greebo Build => 3636
27.06.2008 21:39 greebo Target Version => 0.9.7
13.03.2009 12:33 greebo Status resolved => closed