View Issue Details

IDProjectCategoryView StatusLast Update
0005519DarkRadiantGUIpublic03.02.2021 18:12
ReporterDragofer Assigned ToDragofer  
PrioritynormalSeveritynormalReproducibilityalways
Status closedResolutionno change required 
Product Version2.11.0 
Summary0005519: Model chooser displays incorrect vert counts for some .lwo models
DescriptionIt seems that in some cases, DR's model chooser underestimates the number of vertices on an .lwo model. One such case would be models exported before 0005115 was resolved (prior to DR 2.09), where every patch-based tri has its own 3 unique vertices. This makes it more difficult to identify and fix models that are affected by that bug.

I've attached 2 versions of building_interior_25.lwo, which was originally created with an old version of DR. Re-exporting it with DR 2.11 causes the file size to decrease from 1272 KB to 946 KB, and in Blender the vert count goes down from 43,236 to 28,044, but in DR's model chooser both versions of the model are displayed as having 28,044 verts.
TagsNo tags attached.

Relationships

related to 0005115 resolvedgreebo Export patches: .lwo loses smooth shading 
related to 0005522 acknowledged DR .ase importer should remove vertex doubles, .lwo importer should not 

Activities

Dragofer

Dragofer

03.02.2021 10:32

developer  

building_interior_25.7z (291,651 bytes)
greebo

greebo

03.02.2021 14:18

administrator   ~0013614

Last edited: 03.02.2021 14:19

View 2 revisions

I'm pretty confident that the LWO loader in DarkRadiant combines duplicated vertices, which might explain the change in numbers. When exporting models DR of course uses the loaded result, so this might be the reason why another export run is changing the vertex count.

The Model Viewer also relies on the loaded mesh, that's why you don't see the higher vertex count in the viewer.
Dragofer

Dragofer

03.02.2021 18:12

developer   ~0013621

Alright, that makes clear that there's no problem with the model chooser. I'll close this issue.

Issue History

Date Modified Username Field Change
03.02.2021 10:32 Dragofer New Issue
03.02.2021 10:32 Dragofer File Added: building_interior_25.7z
03.02.2021 10:32 Dragofer Relationship added related to 0005115
03.02.2021 10:33 Dragofer Summary Model chooser displays incorrect vert counts for some models => Model chooser displays incorrect vert counts for some .lwo models
03.02.2021 14:18 greebo Note Added: 0013614
03.02.2021 14:19 greebo Note Edited: 0013614 View Revisions
03.02.2021 14:19 greebo Status new => feedback
03.02.2021 18:10 Dragofer Relationship added related to 0005522
03.02.2021 18:12 Dragofer Assigned To => Dragofer
03.02.2021 18:12 Dragofer Status feedback => closed
03.02.2021 18:12 Dragofer Resolution open => no change required
03.02.2021 18:12 Dragofer Note Added: 0013621