View Issue Details

IDProjectCategoryView StatusLast Update
0003063The Dark ModAIpublic06.07.2020 14:17
ReporterBaddcog Assigned Tograyman  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionTDM 1.07 
Target VersionTDM 1.08Fixed in VersionTDM 1.08 
Summary0003063: Ai ramp up too quickly when player is seen
Description Ai instantly go to full alert and chase player when player is seen.

 Can be pretty unforgiving gameplay, turns off noobs. Ai can see player from very long distance and draw sword and charge immediately.

 Can be hard to escape when ai draws sword immediately.

 Needs a bit of ramp up time.

 Whats that? Oh you... I'm gonna get you... then draws sword/runs, etc...
Additional Information Would be great if this could be solved by 1.08. Might be quite awhile before we see 1.09 and this can turn off players quite quickly.

 TDM is already less forgiving (on purpose) than Thief but this just compounds the issue. Makes it hard to be spotted and escape/not take damage.
TagsNo tags attached.

Relationships

duplicate of 0001395 resolved Minimum reaction time for searching alert 
related to 0005286 assignedstgatilov Number of times seen: not increased when civilian detects player at close range 

Activities

grayman

grayman

13.03.2012 00:40

administrator   ~0004405

http://forums.thedarkmod.com/topic/10173-ai-reaction-time/page__view__findpost__p__200252
grayman

grayman

03.04.2012 21:44

administrator   ~0004438

Last edited: 08.04.2012 01:45

View 2 revisions

Changed the visibility polynomial value to match the wiki.

An AI won't see you, even in full brightness, if the distance between you is > 40m (1,575 Doom units). At that distance, you can see that someone is there, but it's difficult to tell exactly who it is. I.e. a Priest has a lot of red and a Revenant has a lot of red. So we turn the table and assume that an AI can tell you're there, but he can't see enough detail to know you're an enemy.

If an AI starts to search because he might have seen you, he no longer runs if the search point is far away. He will run toward you if he enters Combat mode and stays there. He won't enter Combat mode if farther than 20m (787 Doom units). 20m is set with a new cvar.

The AI barks something from "snd_alert1s" when starting the Combat pause. These barks are of the "huh?" variety.

Pause before fully entering Combat. Check for visibility of player after pause is finished. This gives the player a short time to duck back out of sight. The pause varies from 0.1s to 2s, depending on distance. 2s is the value used at 20m. These are hard-coded. If the AI quits Combat because he can no longer see the player after the pause, he drops back into Agitated Searching. So he will continue to walk toward where he thought he saw you.

Delayed a "player sighting" (for mission stats) until after the Combat pause is over and the AI can still see the player.

Allowed an AI to spot the player regardless of where the AI was in his hiding spot effort. If he had ramped up to AgitatedSearching, he was less likely to spot the player than if he had been in Idle State under the same circumstances.

rev. 5366:

CombatState.cpp
CombatState.h
SearchingState.cpp
AI.cpp
AI.h
SysCvar.cpp
SysCvar.h
MeleeWeapon.cpp

Issue History

Date Modified Username Field Change
12.03.2012 16:23 Baddcog New Issue
12.03.2012 18:01 grayman Assigned To => grayman
12.03.2012 18:01 grayman Status new => assigned
12.03.2012 20:18 tels Relationship added related to 0002924
12.03.2012 20:56 tels Relationship added duplicate of 0001395
13.03.2012 00:40 grayman Note Added: 0004405
03.04.2012 21:44 grayman Note Added: 0004438
03.04.2012 21:44 grayman Status assigned => resolved
03.04.2012 21:44 grayman Resolution open => fixed
03.04.2012 21:44 grayman Fixed in Version => TDM 1.08
08.04.2012 01:45 grayman Note Edited: 0004438 View Revisions
20.03.2013 20:55 grayman Relationship deleted related to 0002924
06.07.2020 14:17 stgatilov Relationship added related to 0005286