View Issue Details

IDProjectCategoryView StatusLast Update
0004932The Dark ModGUIpublic28.02.2020 03:31
ReporterSTiFU Assigned Tostgatilov  
PrioritynormalSeveritynormalReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionTDM 2.07 
Target VersionTDM 2.08Fixed in VersionTDM 2.08 
Summary0004932: Graphical Settings Menu Overhaul
DescriptionThe graphical settings menu becomes quite stuffed with things nobody very touches.
The following things have been proposed (albeit not fully decided):
-Remove Interaction shader and ambient method settings. Leave both on enhanced by default.
-Tweak Soft Shading softness to an appropriate value and remove slider
-Add information popups next to settings for explanation

Most importantly, redesign how Brightness and Gamma is handled:
-If post-processing is on, use post-processing methods for altering these parameters (leaves OS brightness unaffected)
-If post-processing is disabled, use r_brightness and r_gamma and warn user that OS brightness will be affected.
-Make sure both methods use the same mathematical formulas to set brightness and gamma.
-Possibly implement a method to fight color banding in the post-processing path
-Integrate SoftGamma, e.g., by providing a slider for r_ambientMinLevel named something like "Increase ambient lighting".
Additional InformationMenu settings discussion:
http://forums.thedarkmod.com/topic/19781-menu-settings/

SoftGamma discussion from the player's view point:
http://forums.thedarkmod.com/topic/19239-soft-r-gamma/?p=431915
http://forums.thedarkmod.com/topic/19239-soft-r-gamma/?p=431978
TagsNo tags attached.

Relationships

related to 0004705 resolvedstgatilov Soft gamma 
parent of 0004624 closedSpringheel FOV option should use a slider 
related to 0004124 acknowledged System auto-detection: for main menu config settings 
related to 0005165 closedstgatilov Add tooltip explanations to settings in graphics menu 
child of 0004630 closedSpringheel Menu Update 

Activities

Judith

Judith

18.01.2019 08:55

reporter   ~0011402

"-Remove Interaction shader and ambient method settings. Leave both on enhanced by default."

+1. I bet most people don't even know what Interaction shader does.
stgatilov

stgatilov

28.02.2020 03:25

administrator   ~0012245

-Remove Interaction shader and ambient method settings. Leave both on enhanced by default.
   Done in rev 15803.
-Tweak Soft Shading softness to an appropriate value and remove slider
   I think it should not be done. Initially, this slider was missing, but later it was added, and I guess people are glad to have it.
-Add information popups next to settings for explanation
   Extracted to related issue 0005165 --- the only remaining thing really worth doing

-If post-processing is on, use post-processing methods for altering these parameters (leaves OS brightness unaffected)
-If post-processing is disabled, use r_brightness and r_gamma and warn user that OS brightness will be affected.
-Make sure both methods use the same mathematical formulas to set brightness and gamma.
   Due to recent changes of 0004705, there are no OS tables now. Moreover, there is single postprocessing shaders, which is always enabled, and it applies gamma/brightness settings like OS color tables did before.
-Possibly implement a method to fight color banding in the post-processing path
   I think this is impossible. Color banding can be fixed by 1) increasing precision of color buffers, 2) applying gamma conversion before and after every shader, or 3) adding dithering in all shaders.
   But none of these approaches touch postprocessing: all of them must happen long before it.
-Integrate SoftGamma, e.g., by providing a slider for r_ambientMinLevel named something like "Increase ambient lighting".
   Not done. But since ordinary gamma and brightness work without downsides now, there is no need to do it.

Issue History

Date Modified Username Field Change
29.12.2018 08:48 STiFU New Issue
29.12.2018 08:51 STiFU Relationship added related to 0004705
29.12.2018 08:55 STiFU Relationship added related to 0004933
17.01.2019 03:08 nbohr1more Relationship added child of 0004630
17.01.2019 03:13 nbohr1more Relationship added parent of 0003098
17.01.2019 03:14 nbohr1more Relationship added parent of 0004624
17.01.2019 11:22 STiFU Relationship added related to 0004124
17.01.2019 11:23 STiFU Status new => confirmed
18.01.2019 08:55 Judith Note Added: 0011402
28.02.2020 03:02 stgatilov Relationship added parent of 0005165
28.02.2020 03:03 stgatilov Relationship deleted parent of 0005165
28.02.2020 03:03 stgatilov Relationship added related to 0005165
28.02.2020 03:25 stgatilov Note Added: 0012245
28.02.2020 03:27 stgatilov Relationship deleted parent of 0003098
28.02.2020 03:27 stgatilov Assigned To => stgatilov
28.02.2020 03:27 stgatilov Status confirmed => resolved
28.02.2020 03:27 stgatilov Resolution open => fixed
28.02.2020 03:27 stgatilov Fixed in Version => TDM 2.08
28.02.2020 03:31 stgatilov Relationship deleted related to 0004933