View Issue Details

IDProjectCategoryView StatusLast Update
0006105DarkRadiantGeneralpublic23.09.2022 09:51
Reporterdatiswous Assigned Togreebo  
PrioritylowSeveritynormalReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSManjaro xfce 
Product Version3.2.0 
Target Version3.3.0Fixed in Version3.3.0 
Summary0006105: Crash when trying to set default mouse or keyboard bindings
DescriptionWhen in the mouse bindings window or keyboard shortcuts window and I click the button to reset to default, DR crashes
Steps To ReproduceMenu edit
-> Keyboard Shortcuts...

In opened window click on button "Reset to default"

Or:

Menu edit
-> Mouse Bindings

In opened window click on button "Reset all mappings to default"
TagsCrash

Relationships

related to 0005387 closedgreebo segfault when applying a new material to a brush 

Activities

greebo

greebo

23.09.2022 09:11

administrator   ~0015272

Confirmed, there are lots of warnings emitted when wxutil::TreeModel::Clear() is invoked. Maybe something changed in wxGTK 3.2

0 0x00007ffff54f5c0c in () at /usr/lib/libgtk-3.so.0
0000001 0x00007ffff5518914 in () at /usr/lib/libgtk-3.so.0
0000002 0x00007ffff59f9fd0 in g_closure_invoke () at /usr/lib/libgobject-2.0.so.0
0000003 0x00007ffff5a26838 in () at /usr/lib/libgobject-2.0.so.0
0000004 0x00007ffff5a17c85 in g_signal_emit_valist () at /usr/lib/libgobject-2.0.so.0
0000005 0x00007ffff5a17f14 in g_signal_emit () at /usr/lib/libgobject-2.0.so.0
0000006 0x00007ffff6e61441 in wxGtkDataViewModelNotifier::ItemDeleted(wxDataViewItem const&, wxDataViewItem const&) ()
    at /usr/lib/libwx_gtk3u_core-3.2.so.0
0000007 0x00007ffff6d546a7 in wxDataViewModel::ItemDeleted(wxDataViewItem const&, wxDataViewItem const&) () at /usr/lib/libwx_gtk3u_core-3.2.so.0
#8 0x00007ffff7c8ebca in wxutil::TreeModelFilter::ChildModelNotifier::ItemDeleted(wxDataViewItem const&, wxDataViewItem const&)
    (this=0x55555853fcf0, parent=..., item=...) at /home/greebo/DarkRadiant.git/libs/wxutil/dataview/TreeModelFilter.cpp:31
0000009 0x00007ffff6d55050 in wxDataViewModel::ItemsDeleted(wxDataViewItem const&, wxDataViewItemArray const&) () at /usr/lib/libwx_gtk3u_core-3.2.so.0
0000010 0x00007ffff7c7d119 in wxutil::TreeModel::Clear() (this=0x555558637fc0) at /home/greebo/DarkRadiant.git/libs/wxutil/dataview/TreeModel.cpp:288
0000011 0x0000555555b3d170 in ui::ToolMappingDialog::populateListStore() (this=0x5555586752a0)
    at /home/greebo/DarkRadiant.git/radiant/ui/mousetool/ToolMappingDialog.cpp:83
0000012 0x0000555555b3dd8a in ui::ToolMappingDialog::onResetToDefault(wxCommandEvent&) (this=0x5555586752a0, ev=...)
    at /home/greebo/DarkRadiant.git/radiant/ui/mousetool/ToolMappingDialog.cpp:192
0000013 0x0000555555b4237d in std::__invoke_impl<void, void (ui::ToolMappingDialog::*&)(wxCommandEvent&), ui::ToolMappingDialog*&, wxCommandEvent&>(std::__invoke_memfun_deref, void (ui::ToolMappingDialog::*&)(wxCommandEvent&), ui::ToolMappingDialog*&, wxCommandEvent&)
greebo

greebo

23.09.2022 09:45

administrator   ~0015273

This appears to be caused by the workaround that has been introduced to fix a crash in wxGTK 3.0.5+. It doesn't seem to be necessary anymore in wxGTK 3.2.0.

Related Changesets

DarkRadiant: master b0bc6020

2022-09-23 09:49:44

greebo

Details Diff
0006105: Disable the workaround in wxGTK 3.2.0 which appears to be counter-productive.

It has been introduced to solve a problem in wxGTK 3.0.5+, which doesn't seem to be
present anymore in in wxGTK 3.2.0. Original issue was 0005387.
Affected Issues
0005387, 0006105
mod - libs/wxutil/dataview/TreeModel.cpp Diff File

Issue History

Date Modified Username Field Change
22.09.2022 15:06 datiswous New Issue
22.09.2022 15:06 datiswous Tag Attached: Crash
23.09.2022 09:11 greebo Status new => confirmed
23.09.2022 09:11 greebo Note Added: 0015272
23.09.2022 09:44 greebo Relationship added related to 0005387
23.09.2022 09:45 greebo Note Added: 0015273
23.09.2022 09:45 greebo Assigned To => greebo
23.09.2022 09:45 greebo Status confirmed => assigned
23.09.2022 09:45 greebo Target Version => 3.3.0
23.09.2022 09:50 greebo Status assigned => resolved
23.09.2022 09:50 greebo Resolution open => fixed
23.09.2022 09:50 greebo Fixed in Version => 3.3.0
23.09.2022 09:51 greebo Changeset attached => DarkRadiant master b0bc6020