View Issue Details

IDProjectCategoryView StatusLast Update
0003007DarkRadiantDesign/Codingpublic11.10.2012 19:03
Reporterbofh80 Assigned Toorbweaver  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platform64bitOSLMDE XFCE linux (debain testing)OS Version3.0.0-1-amd64
Product Version1.7.0 
Fixed in Version1.8.0 
Summary0003007: Entity > Classname > Choose entity class *Segmentation Fault* XreaL
DescriptionHighlighting / selecting anything in a map, Entity Tab, select classname, press 'Choose entity class..' . Segmentation fault.

I'm using the XreaL gamepack. And Doom3 it seems (although i don't have doom3, i just selected it as the game type, reloaded radiant and created a blank brush, pushed the button).
Steps To ReproduceEntity Tab, select classname, press 'Choose entity class..'
Additional Information(gdb) run
Starting program: /usr/local/bin/darkradiant ./darkradiant
[Thread debugging using libthread_db enabled]
[New Thread 0x7fffd82a5700 (LWP 28081)]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff5d235a0 in Gtk::TreeModel::foreach_iter(sigc::slot<bool, Gtk::TreeIter const&, sigc::nil, sigc::nil, sigc::nil, sigc::nil, sigc::nil, sigc::nil> const&) () from /usr/lib/libgtkmm-2.4.so.1

(gdb) bt


#0 0x00007ffff5d235a0 in Gtk::TreeModel::foreach_iter(sigc::slot<bool, Gtk::TreeIter const&, sigc::nil, sigc::nil, sigc::nil, sigc::nil, sigc::nil, sigc::nil> const&) () from /usr/lib/libgtkmm-2.4.so.1
0000001 0x00007ffff0702ba0 in gtkutil::TreeModel::findAndSelectString (view=0x1f41bf0, needle=<value optimized out>,
    column=<value optimized out>) at TreeModel.cpp:84
0000002 0x00000000005dfc80 in ui::EntityClassChooser::setSelectedEntityClass (this=0x1f29ee0, eclass=...)
    at ui/entitychooser/EntityClassChooser.cpp:252
0000003 0x000000000065ca4e in ui::ClassnamePropertyEditor::_onBrowseButton (this=<value optimized out>)
    at ui/einspector/ClassnamePropertyEditor.cpp:59
0000004 0x00007ffff47ac638 in Glib::SignalProxyNormal::slot0_void_callback(_GObject*, void*) () from /usr/lib/libglibmm-2.4.so.1
0000005 0x00007ffff28b5e7e in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
0000006 0x00007ffff28c7ab2 in ?? () from /usr/lib/libgobject-2.0.so.0
0000007 0x00007ffff28d0d05 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#8 0x00007ffff28d0ed3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
0000009 0x00007ffff4a60ec5 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
0000010 0x00007ffff28b5e7e in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
0000011 0x00007ffff28c709c in ?? () from /usr/lib/libgobject-2.0.so.0
0000012 0x00007ffff28d0d05 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
0000013 0x00007ffff28d0ed3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
0000014 0x00007ffff4a5fc7d in ?? () from /usr/lib/libgtk-x11-2.0.so.0
0000015 0x00007ffff4b0ad48 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
0000016 0x00007ffff28b5e7e in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
0000017 0x00007ffff28c76e8 in ?? () from /usr/lib/libgobject-2.0.so.0
0000018 0x00007ffff28d0aa5 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
0000019 0x00007ffff28d0ed3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
0000020 0x00007ffff4c26d8f in ?? () from /usr/lib/libgtk-x11-2.0.so.0
0000021 0x00007ffff4b08f03 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
0000022 0x00007ffff4b092b3 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
0000023 0x00007ffff40dfb7c in ?? () from /usr/lib/libgdk-x11-2.0.so.0
0000024 0x00007ffff1feb4a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000025 0x00007ffff1febc80 in ?? () from /lib/libglib-2.0.so.0
0000026 0x00007ffff1fec2f2 in g_main_loop_run () from /lib/libglib-2.0.so.0
0000027 0x00007ffff4b082b7 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
0000028 0x0000000000524a9c in main (argc=2, argv=0x7fffffffe908) at main.cpp:173
TagsNo tags attached.

Activities

bofh80

bofh80

04.02.2012 03:06

reporter   ~0004294

*updated to include debugger info and game pack change test.
orbweaver

orbweaver

07.02.2012 20:51

developer   ~0004312

Confirmed, caused by my threading changes in the entity class tree.
orbweaver

orbweaver

08.02.2012 19:56

developer   ~0004316

Fixed in revision 7041.

Issue History

Date Modified Username Field Change
04.02.2012 01:40 bofh80 New Issue
04.02.2012 03:06 bofh80 Note Added: 0004294
04.02.2012 03:06 bofh80 Description Updated View Revisions
04.02.2012 03:06 bofh80 Additional Information Updated View Revisions
07.02.2012 20:51 orbweaver Note Added: 0004312
07.02.2012 20:51 orbweaver Assigned To => orbweaver
07.02.2012 20:51 orbweaver Status new => assigned
08.02.2012 19:56 orbweaver Note Added: 0004316
08.02.2012 19:56 orbweaver Status assigned => resolved
08.02.2012 19:56 orbweaver Fixed in Version => 1.8.0
08.02.2012 19:56 orbweaver Resolution open => fixed
11.10.2012 19:03 greebo Status resolved => closed